: Car Audio Help Please



02cadi
08-03-08, 05:11 PM
hey guys im new here and i need help ASAP. i am an owner of a 2002 escalade suv. I have the stock original deck and speakers, everything is hooked up but there is no sound. i was told that there is no amp in there from the previous owner. can anyone tell me where that would be located so that i can check for myself? i am going on a road trip this weekend and im in need of some serious tunes! please let me know what you guys can help me with, thanks!

CadillacSTS42005
08-03-08, 07:46 PM
its either behind the glove box or behind the rear 1/4 trim panel

02cadi
08-03-08, 08:44 PM
i found it in the rear quarter panel with the stock sub. except for there is no amp, hahaha its disconnected and taken out. do you know if there is more than one amp? or is it just this one and if i get it then i will be ok? because as of right now i dont have any noise coming out of it at all. thanks man!

CadillacSTS42005
08-03-08, 09:03 PM
should b 1 amp

eechapa
08-06-08, 05:05 PM
I have a 2003 Deville that i need to remove the Radio to install a fm modulator on the antenna but i need to find out how to remove the radio can you help me my telling me how to remove the radio to get to the antenna wire!!

CadillacSTS42005
08-06-08, 07:53 PM
plz make new post

DesignKid
08-25-08, 12:03 AM
Replacing the factory amplifier should solve your problem, but you could also run all new speaker wire from the back of the radio to each speaker to bypass the amplifier. Just another option.

As for the guy who stole your post, to remove the radio in a 2003 Deville you need to unsnap and remove the trim panel surrounding the climate controls and radio. You then remove the radio by depressing clips on each side, and pulling outward.