: Not starting!



250motorsportz
07-15-08, 04:28 PM
Well, I came home last night after work and left the Escalade in the driveway, went out to leave again and the truck wouldn't start! It turns over and everything, battery is fine, there's enough gas, but it'll start then shut off within half a second. What's wrong here? I even neutraled it back onto the road(downhill) to see if that would help, moved the steering column up and down, left and right. Nothing! It seems like it wants to start but can't stay started. I have almost half a tank of gas in it.

g9s8r
07-15-08, 04:49 PM
wish I was a mechanic to help ya out. Only things I can think of is fuel or spark. Check to see if the fuel pump is working (common problem with chevy trucks), fuel filter plugged. Or maybe its not getting spark.

250motorsportz
07-15-08, 05:10 PM
It's getting spark. How do I check if the fuel pump is working?

B.S.!!!!! Can't believe I'm having so many problems with this truck and my CTS! The days I really need my truck, it f***s up!

I am pretty sure its the fuel pump gone. Another few days gone without a vehicle!

Has anyone here installed a fuel pump themselves? All the shops in town are backed up for a good week or two.

g9s8r
07-15-08, 07:27 PM
Hmm... like I said.. i am no mechanic so I have no real answers. I know when I had my chevy truck. I was able to turn the ignition to the on position without starting it and hear my pump turn on. I've only had my Ext for like 2 weeks so I don't have much experience with it yet. Not sure if it is as loud as a Chevy and the same method would work.

As far as installing one... I just know my Chevy...it was an intank and it was a B*tch to replace cause you have to drop the fuel tank. Hopefully someone with more experience with this will chime in.

ewill3rd
07-15-08, 09:00 PM
A start/stall condition on that type of vehicle could indicate a theft deterrent problem.
Any lights blinking at you when it does this?
What year is your vehicle?

250motorsportz
07-15-08, 11:06 PM
A start/stall condition on that type of vehicle could indicate a theft deterrent problem.
Any lights blinking at you when it does this?
What year is your vehicle?

No lights blinking. It is a 03 I believe. I will most likely get it towed down to the local Chevy Dealer tomorrow and get them to find out whats wrong. Hopefully something a lot smaller than a fuel pump! I already checked all the fuses.

ewill3rd
07-16-08, 06:52 AM
It probably needs an ignition switch.
The earlier ones had an resistor capacitor filter built into the passlock harness in the steering column.
This filter has a tendency to go bad and cause a failure when the passlock module reads the lock cylinder.
This will cause the engine to start and then shut right back off over and over again.

It is part of the electrical ignition switch assembly.