: Mechanics - Chicago area - Help

07-15-08, 04:48 PM
Does anyone found a good, decent mechanic that tells you exact if you need to change only what you really need to change?
Please help, I need to find a mechanic that i can trust to leave the car in the shop until he fixes it. NW Chicago would be perfect, but I can drive a bit further for a good mechanic.
Thank you!

07-24-08, 06:47 PM
Dugan's Auto in Sugar Grove is good. The owner, Mike, basically works out of his barn, but the guy is honest and truthful. I've taken misc things on two Cadillacs to him. He doesn't have all the computer stuff that the dealerships have, but he still knows his stuff.

07-24-08, 11:34 PM
whats wrong with the car....

09-19-08, 03:47 PM
Thanks for info. i'll try it soon.
The idle is kind of shaky at cold starts. I changed the plugs, cleaned the EGR valve and TB, checked the FPR. I'll check the injectors and the coil. After that i don't have any idea what my next target will be.

09-19-08, 03:54 PM
Head gasket, maybe

09-19-08, 05:36 PM
isn't that supposed to cause the coolant level to drop. i've been checking the level for the past 3000 miles - No changes. There is a slight irregular idle after it warms up too but not as bad as when cold. I don't get any codes beside TCC stuck off/on. i remember when i changed the plugs, two of them had a gas smell. I can check them again and also check for a vacuum leak.

09-19-08, 07:26 PM
Yeah - if coolant is leaking into the cylinders and causing rough running when first started cold, your coolant level would have to be going down

10-07-08, 05:51 PM
Actually there is a slight irregular idle even after warming up the car, but not as bad as when cold.
I noticed a strange noise, like a vacuum leak on the left side of the engine (highlighted in yellow) Any suggestion where that leak could be? When the engine is hot I guess the gap becomes smaller and the idle gets better but still, every 15-30 sec I can hear that noise.
Thank you

10-07-08, 06:00 PM
Call Rob at Tepco. He is a friend of mine and is a great mechanic and enthusiast.

3810 W. Belmont Ave
Chicago, Illinois 60618

Tell him Elias with the black Fleetwood sent you :thumbsup:

10-07-08, 06:15 PM
Thank you Elias

10-07-08, 06:18 PM
I messed to attached the picture.

10-07-08, 10:22 PM
That is where the manifold over pressure relief valve is. It's tucked way back in the manifold, behind the P/S pump, but you can see and feel it if you try. It's just a big spring loaded flap. Probably just a bad or dirty seal.

10-08-08, 06:13 PM
How can I get that fixed? Do I have to take out the manifold to access it and clean?
It makes the same noise when I accelerate and couple of second after. At idle I can hear it once every 30 sec or so, when the idle is not steady.
Could that be the cause of my idle issue?

10-08-08, 08:51 PM
Most likely you will have to remove the manifold, but you could try getting you fingers in there. it's behind the P/S pump and pretty tight as I recall.