: Bad echo when I use my STS's bluetooth to talk



hangelsts
07-07-08, 11:07 PM
:( I have my blackberry set as the default bluetooth device in my 07 STS with Nav system. Whenever I make a call to anyone, regardless of whether they are on a cell phone or land line, they get a terrible echo, which renders the bluetooth in my STS unusable (no one can stand to talk to me using the bluetooth connection. I can call back using a earpiece and they have no echo, so its something in the Nav system/bluetooth of the STS.

I called cadillac's hotline----- worthless use of 30 minutes. they said to go to the dealer (as if a mechanic is also a telecom/bluetooth expert.



Is there a software fix? Is anyone else having this problem?

drjdan
07-08-08, 01:24 AM
I would try someone elses phone to test. If also has problem, I would say it is Cadillac's problem to fix.

Skibanker
07-09-08, 10:30 PM
Go into the phone's bluetooth settings and set the echo control to "On". The default setting is "Auto", but that doesn't work nearly as well as ON. Good luck.

drjdan
07-09-08, 11:18 PM
Go into the phone's bluetooth settings and set the echo control to "On". The default setting is "Auto", but that doesn't work nearly as well as ON. Good luck.

Are you talking about the setting in cell phone or the bluetooth settings on STS bluetooth?

jgrade
07-10-08, 09:27 AM
hangelsts (http://www.cadillacforums.com/forums/member.php?u=74471): Besides the issue of overriding the nav lockouts, this has to be the most discussed issue. I don't mean to blast a new member but seriously, use the search.:helpless: The echo has plagued the BT on this car with not much releif for a long time. Just color yourself lucky you were able to pair the phone and that it actually mutes during incomming calls. The BT feature was not engineered or tested very well for a luxury vehicle.

By the way, :welcome:

byron.hopp
09-21-08, 01:22 AM
My echo problem was I had the volumn up too loud. I have a friend (IBM retiree) and simply ask me to turn down the volumn because it was causing an echo. Now everybody has stopped complaining... Forget India, those old IBM guys are good.

ewill3rd
09-21-08, 08:29 PM
Depending on the build date there is a software update that is available for the radio that should fix this issue.
(SHOULD)
If your dealer can't the bulletin I can steer you in that direction.
I have posted a few times on this topic.

drjdan
09-21-08, 09:04 PM
Depending on the build date there is a software update that is available for the radio that should fix this issue.
(SHOULD)
If your dealer can't the bulletin I can steer you in that direction.
I have posted a few times on this topic.

I have a 2008 STS, would update apply?

I get the buzz most of the time. If I adjust the volume up or down one click, the buzz never happens.

ewill3rd
09-22-08, 06:49 AM
Supposedly they changed part numbers and operating software for the '08 model year.
On the '08's I have seen the TSB will not work.