: Seville CD changer reads CD ERROR



vacuumbed
07-02-08, 09:22 PM
Hi,
I probably should have placed this in the audio section but wanted input from other 98-04 Seville owners.

My 6 disc changer in the console on my 03 Seville has a hard time reading discs that otherwise work fine in other CD players. It reads CD ERROR on some discs when the magazine is inserted. It does not have any mechanical problems that I can tell.

I think the changers in these cars are a bit tempermental. Is that true?

Ranger
07-02-08, 09:54 PM
Is it a Bose? MY '03 (Bose) does not like copies that played well on my '02 (non Bose). I get the same CD ERROR.

vacuumbed
07-02-08, 10:24 PM
Yea it's a Bose with Navigation.

It gives me a real pretty CD ERROR message on my Navigation screen. LOL

Ranger
07-02-08, 10:32 PM
Are you using original or copied CD's?

vacuumbed
07-02-08, 10:42 PM
They are all original.

Ranger
07-02-08, 10:50 PM
So much for my theory.

vacuumbed
07-02-08, 10:57 PM
I may need to try and clean the CD's. Thanks for your input. :)

vacuumbed
07-15-08, 08:07 PM
After cleaning the CD's and even adding a brand new CD from the store the problem still exists.

Somtimes it will read a CD just fine and other times it gives the CD ERROR message.

I think there is somthing wrong with the changer.

CadillacSTS42005
07-15-08, 11:53 PM
unplug the changer
plug it back in
should fix it

coderwil
12-04-08, 10:54 PM
I am having a similar issue with my 2004 DHS. I was hoping that someone came across a fix? Regarding the 'unplug and replug' comment. Can anyone tell me where to find this plug to reconnect?

Thanks,
William

bigsxc
04-14-10, 08:14 AM
DId anyone respond to your question of unplugging? Im having the same exact problem in an 01'STS with original and burned cd's....Sometimes it will play sometime it wont?

coderwil
04-14-10, 12:21 PM
Unfortunately, I did not receive a response, and I am still experiencing the continued problem.

Hopefully this bump will have some kind soul to give some direction. My cd changer is located in the glove box.

William

bigsxc
04-14-10, 02:06 PM
Yeah mine too in the arm rest ... I was thinking about just replacing the changer to see if that works. I dont want to put a new system in it.. It will take away from the look! :)

Submariner409
04-14-10, 03:51 PM
By "unplugging" the changer means to remove it as if you were inserting new CD's. Snap it shut and insert it back into the receptacle. That usually cures the error message and restores the CD stack icon to the Source readout.

boricuacaddy
04-15-10, 11:21 AM
I had the same issue on my 97 Seville. My changer is mounted in the trunk. I just unplugged it from the harness and waited 15 seconds and plugged it back in and it was all good from there on.. "Knock on wood"


David

Submariner409
04-15-10, 11:39 AM
...........caused by a serial data error in the sound system info loop. Unplug, plug re-sends the accessory info.