: NO dash lights!!!



boomerang
06-26-08, 09:02 AM
2 nights ago after we cranked the 2002 Escalade we had no dash lights. Everything else seems to work fine...headlights, taillights, interior lights, stereo, everything but the dash lights. Any ideas that might help us find the problem???

hcvone
06-26-08, 09:11 AM
You don't have them dimmed out do you? Did you check the fuses?

DLE
06-26-08, 03:26 PM
Yeah, check the dial on the left. Make sure its not dimmed. And of course, dont forget to check the fuse.

boomerang
06-26-08, 07:14 PM
First thing we did was check the dimmer switch. Rolled it up, rolled it down - rolled it down, rolled it up...still no lights.
Then we checked the fuses. Both those in the left side of the dash AND those under the hood. Found one 15 amp fuse, under the hood, "CIGAR", blown. Replaced it...yet no lights.
What to do, what to do???

TheCaddyKidd
06-26-08, 11:41 PM
On my 06 I had a problem where my cluster and A/C lights were not coming on. Turned out to be a fuse. I think it was labeled as Truck Module 3 or something like that. Make sure you check every single fuse. This fuse happened to inside the vehicle by the driver door.

boomerang
06-29-08, 11:53 PM
Okay...for those who MAY face this problem in the future, our problem turned out to be a worn out Dash Light Switch (which is actually a module that is easily R&R'd in about 5 minutes). The part runs anywhere between $72 & $92 from you local parts store (it is not a stocking item but can be ordered for next day pickup).
Good luck to one and all!!!

hcvone
06-30-08, 08:16 AM
Thanks for the update. :)

chemman14
07-18-08, 03:04 PM
Okay...for those who MAY face this problem in the future, our problem turned out to be a worn out Dash Light Switch (which is actually a module that is easily R&R'd in about 5 minutes). The part runs anywhere between $72 & $92 from you local parts store (it is not a stocking item but can be ordered for next day pickup).
Good luck to one and all!!!

how did you troubleshoot this?? i am having the same problem

boomerang
07-23-08, 02:41 PM
Actually have a friend who is an ASE certified mechanic. He advised that the switches are known for their failure. He popped it out, then opened it up and saw "corrosion" in the rheostat that dims and brightens the interior lights. Picked up a new one...about $60.00...plugged it in and WALLAH!!! The lights all were on!!!
It's a very easy R&R. BTW, if the parts house tells you it's $200 then they're trying to sell you the headlight dimmer switch on the steerig column!

julioromero
08-10-11, 10:00 PM
how did you troubleshoot this?? i am having the same problem
The Owners Manual page 421 refers to the LBEC Fuse. I just Replaced it, it is a red 50 Fuse and all is back to normal.
it is on the fuse panel under the hood.