: My car has the shakes



pete15cool
06-20-08, 11:47 AM
When my car is in park or neutral it shakes. I turned off the a/c and still stakes. I notice the gas mileage dropped from 20 to 16 mpg. I might think it is the maf. I attached some pictures to the forum. I was think of the getting an ohm meter to measure the IAT sensor or air temp sensor. I know the power of the maf.

there are five wire
staring from the left

yellow
black with white stripe
red with black stripe - power wire
orange - maybe maf
orange - maybe maf

Can someone tell me which is Intake temp sensor and ground.

Thank You,

Pete
Last time I check, air flow sensor can cost up to $300

pete15cool
06-20-08, 11:49 AM
Sorry here is the picture.

Again,


Thank You,


Pete

ascariSTS
06-20-08, 04:35 PM
I'm not sure if throttle body has anything to do with this. My car's shakes started after they replaced the throttle body.

I wonder if anyone has a clue.

dkozloski
06-20-08, 05:29 PM
What codes are you getting?

pete15cool
06-21-08, 08:33 PM
No codes right now but recently I changed the air filter for stock to K&N air filter.

Pete

dkozloski
06-21-08, 09:54 PM
It is very common for a cold air intake to upset a Northstar and cause it to run lousy as well as providing very limited to no benefit. I'd put it back like it was. Also a little excess oil on a K & N filter element kills a MAF until you can get it clean again.

C&C
06-22-08, 06:25 AM
Dk is right, it may be oil on the MAF sensor. These can be cleaned but you need a specific MAF sensor cleaner, and you need to be careful as they are fairly delicate.
I had a similar problem with my Olds Bravada, and thought I had messed up my MAF (I had just switched to K&N) but after diagnosis, it was determined to be an O2 sensor; so in my case, it was just a coincidence that I had changed the air filter. This may also be the case with you.

pete15cool
06-23-08, 09:51 AM
Can ANYONE tell me which temp sensor wire is on the MAF? I have listed the color above.