: ABS pump and ride control.



Orlie
06-17-08, 10:28 AM
I just bought a 2002 Escalade 2 wheel drive with a 6 inch lift and 35" tires, 88000 miles.

My problem is the abs pump was unplugged because the abs pump was always running. The abs and traction control lights are on. I aslo have the ride control service light on. For the ride control I have looked at all the level sensors, they are connected and I can hear the air pump come on every so often to level the suv. What can I check to get the service ride control warning to turn off. Also does the stock air ride use airbags in the coils, or is it just air shocks.

For the abs pump, I found a company that will rebuild my abs module for 180 bucks. Has anyone done this, and did it work.

One more question, can any of these problems be caused by 35" tires.

Thanks
Orlie

Orlie
06-18-08, 09:24 AM
You got to be kidding me that nobody can answer this question. I thought that with all the problems with the air ride, abs module that someone on here would know something about these problems. I hope im not wrong.

later
Orlie

Rolex
06-19-08, 06:27 PM
Rebuilding the ABS will work. I did the same thing on my 1999 GMC Sierra when the ABS went out. If you don't unplug them they will just keep running until the battery goes dead.

And any number of things could be setting off your sensors. Who did the work on on the suspension?

Orlie
06-19-08, 08:06 PM
The lift was done by a company in phoenix, custom lift. Its using the original air shocks and the height sensors are plugged in. Any other ideas.

later
Orlie