: Slight grinding noise behind the instrument cluster



hermxl1
05-14-08, 01:20 PM
Hi all,

I have an 04 Escalade that I bought in 05 with 1500 miles on it and I have always heard this small grinding sound behind the dash on the drivers side. I almost sounds like an old electric analog clock. It a very low sound and not really audible accept when idling in park but is there while driving also. I took it to the dealer once and they replaced the whole instrument cluster and the sound went away for about a month but came back.

Anyone else have this? Any ideas on what it could be?

Randy Clark
05-14-08, 01:57 PM
Hello, I have an O4 Escalade that I just purchased and I seem to have the same sound but more toward the middle of the dash and favoring the pasenger side. My noise seems to be related to the AC when its on.. it goes away when I push the AC * button, and comes back when it turn it back on. I know what AC systems sound like, and what to expect from them, but mine too sounds like an old clock sound..

hermxl1
05-15-08, 05:02 PM
Well since I hear mine in the winter also, I know its not AC related, but lately I've been thinking its something under the hood possibly. Still a mystery to me.

Caddydude420
05-15-08, 08:15 PM
I had the same thing. I think it happened whenever I had the air or went on. It just went away.

After that though, I had to replace the gauges under warranty. My "service air bag" light has been on though.

Problem time line:
Intermitent grinding noise -> Service Air Bag light -> SAB went away for a couple months -> gauges acted up and had them replaced under warranty -> SAB light is back on. I haven't heard the grinding noise in a long time though.