: 02 Escalade stalled-Need Help



Big John (NYC)
04-27-08, 06:30 PM
Hello,
I've been lurking on these forums for a few year now 1st with my 2000 STS and now with my 02 Escalade. I really hope someone can help me before I call for the flatbed.
Last night, my wife was driving the 02 Escalade following me home. We had only been traveling about 2-3 blocks when the Escalade started jerking as if the throttle and brakes were being pumped simultaneously. My wife immediately called me, and we pulled over. By the time I got out of my tuck and got to the Escalade it barely had an idle and then stalled, I tried several times to restart it and 50% of the time I barely had an idle for a few seconds and then it would stall or it would just crank. My instincts tell me it's not getting fuel (it has 1/2 a tank). I tried to listen for the fuel pump and did not hear anything, although I don't remember if the Escalades pump was ever hearable. It was 2am when this occured so I wasn't in the best frame of mind. I grabbed the manual and checked the fuel relay, swappped it with another but no change. What else should I look for? Is there a fuse somewhere that I'm not seeing? The glove box manual isn't too clear on what to look for. I'd hate to pay for a wrecker to pick up my escalade to bring to the dealer just to find out it was a fuse I didn't see.
Please, any help will be greatly appreciated.
BTW- It has 115k on it.


Thanks,
Big John NYC:cool2:

superdips
04-28-08, 01:40 AM
Hello,
I've been lurking on these forums for a few year now 1st with my 2000 STS and now with my 02 Escalade. I really hope someone can help me before I call for the flatbed.
Last night, my wife was driving the 02 Escalade following me home. We had only been traveling about 2-3 blocks when the Escalade started jerking as if the throttle and brakes were being pumped simultaneously. My wife immediately called me, and we pulled over. By the time I got out of my tuck and got to the Escalade it barely had an idle and then stalled, I tried several times to restart it and 50% of the time I barely had an idle for a few seconds and then it would stall or it would just crank. My instincts tell me it's not getting fuel (it has 1/2 a tank). I tried to listen for the fuel pump and did not hear anything, although I don't remember if the Escalades pump was ever hearable. It was 2am when this occured so I wasn't in the best frame of mind. I grabbed the manual and checked the fuel relay, swappped it with another but no change. What else should I look for? Is there a fuse somewhere that I'm not seeing? The glove box manual isn't too clear on what to look for. I'd hate to pay for a wrecker to pick up my escalade to bring to the dealer just to find out it was a fuse I didn't see.
Please, any help will be greatly appreciated.
BTW- It has 115k on it.


Thanks,
Big John NYC:cool2:


Hey John,
Keep an eye on my thread as well, there might be something that gets posted there that might help you too. My truck aint starting right now either and i have no idea whats going on.

hcvone
04-28-08, 08:16 AM
How long ago was it when you had the last major tuneup?

Big John (NYC)
04-28-08, 12:32 PM
How long ago was it when you had the last major tuneup?



Actually, now that Spring is here, I was planning on giving the Escalade her 1st tune-up.
Up until this latest not starting problem, she was running GREAT.
It didn't even throw a code before she stalled. I really hope it's something simple.
Either way, I guess my tax rebate is going to the Escalade. :nono:


Big John (NYC):cool2:

hcvone
04-28-08, 02:25 PM
Do the tune up, but you may have a fuel pump starting to go

slk230mb
04-29-08, 07:32 AM
It could also be a seriously dirty throttle body.

cadillacroadside
04-29-08, 11:02 AM
if you are under the vehicle and have someone put the key to the run position you should be able to hear the pump run for a few seconds, if you cannot, move to the schraeder valve under the hood on the fuel line (if you do not have a fuel pressure gauge) put on safety glasses and depress the valve with a small screw driver if fuel does not squirt out the pump is more than likely your problem and is very common failure on these vehicles

Big John (NYC)
04-30-08, 12:46 AM
***UPDATE***
Well apparently it was indeed my fuel pump that was the cause of trouble.
$500 bucks later the Escalade is back home where she belongs and running fine. Thanks for all the advice.

Big John (NYC):cool2:

hcvone
04-30-08, 06:51 AM
Thanks for the update, now a tune up and you should be good to go for a while. :)

friscoCADDY
05-02-08, 01:24 AM
Sorry for not seeing this earlier but I had the same problem in my 2002 around the same mileage.. its the fuel pump but when you do the tune up I HIGHLY recommend you clean your Tbody.. ive replaced fuel pumps, filters, plugs only to find out that my car would stall (not osilate like yours did becaue mine did too when my fuel pump when) at low RPM due to a dirty Tbody.

cain0main
05-15-09, 11:21 AM
how do you clean the throttle body and where is it? Should I do this myself?

pcguy760
05-16-09, 03:15 AM
Hmmm... I think some regular "Throttle Body Cleaner" from the auto parts start should do it. Most of them have pretty good instructions on the back of the spray can - which reminds me I should do that too lol.

Patrick7997
05-17-09, 09:06 AM
Use the throttle body cleaner that says "oxygen sensor safe" on the can....

And yeah, you can hear the fuel pump running when you turn the key on... If you don't hear it, well, there's your problem.