: 6 cd changer won't eject magazine



yam700
04-25-08, 08:02 AM
Hi everyone,
We have an 01 sts and I got in the car last night an their was an error for the cd changer. I tried to eject the magazine but it won't come out, it just clicks and on the display it shows it trying to read the discs. After a few seconds it stops trying and says no source loaded. I tried pushing the reset button beside the eject but with no luck. Please help we are going away for the weekend.

Thanks!

blacklack
04-25-08, 12:49 PM
Mine did the same thing on a 04 dts I just unplugged the connector from the back of the cd changer plugged it back in an it started working fine.

yam700
04-25-08, 02:14 PM
Thanks, I'll give it a try when my wife gets home with it!

yam700
04-29-08, 07:01 PM
Tried unplugging the unit and plugging it back in and it made no difference. So the only thing left was to take it apart. When I removed the covers I found that it tried to put 2 cd's in the same slot. I was eventually able to get it out and then I was able to remove the magazine. Put it all back together minus the covers and tried it in the car. The deck won't initialize, their must be something bent or out of sinc. The table tries to move but it is like it is jambed. This would explain why it tried to place 2 in the same slot, it couldn't make it to its next location. Their could be more wrong here as well. It should look to see if a location is occupied and if it is then it should move to the next location and check for a cd. If the location is empty then it should place the cd in this spot and if it sees a cd move to the next available. Does anybody have a repair manual for this deck?

Thanks

kimmer
09-27-10, 04:19 AM
I had the same problem. It wouldn't eject the mag. Finally after resetting it ejects the mag but still says no source loaded and wont acknowledge after initializing.

No music. 1999 Cadillac Seville SLS

any ideas

N*Caddy
09-28-10, 10:33 PM
There is a small reset button accessible with a paper clip or a needle located above the sliding door.
If that does not work then what ever you do please for the sake of the CD changer do NOT force the magazine out (or you bend the mechanics inside). Take your time, open it up and see what is causing the jam (probably one of the disks stuck half way).

Kimmypage
07-12-12, 12:36 PM
.. BUMP... say, I just got a 2003 STS, and the magazine won't eject... I can not find this "reset" button either... Where exactly is it?
Also, it makes NO effort at all, like it's dead.... HELP, what a waste of a good stash spot, if this CD thing is broke...

(Newly back, this is the prior "97cherry", back on the boards...)

~ Hi Ranger !! :)

Submariner409
07-12-12, 01:19 PM
One time I had to physically push down on the CD cassette, let it pop back up, pushed down again, hit the Eject latch and out it came. Never got stuck again. Worth a try.

Got yourself one of the few hot rod F55 STSs, huh ??

Kimmypage
07-13-12, 12:33 PM
.. I tried again, to remove the magazine... it's got NO power to it, methinks...confirmed by our IT guy at the office... :)
how can I be sure? What fuse to check? Where is a connection i can check?

Submariner409
07-16-12, 10:16 AM
Kimmy, Your other car questions and/or info have been moved to the Seville Forum in a new thread - 2003 STS - What do I have" ?

You might find it interesting to check in there before the thread slides down the page and goes quiet because it's out of sight.

Kimmypage
07-17-12, 09:56 AM
Mine did the same thing on a 04 dts I just unplugged the connector from the back of the cd changer plugged it back in an it started working fine.

where is 'the back of cd changer'???? I looked for a reset button and never found one.... what number fuse should I check?
I don't think it's getting any power at all, and might be disconnected ??? Errrr, please, this sucks... what a waste... :(