: camshaft sensor



johnpage
04-02-08, 08:03 PM
just replaced camshaft sensor after car died on me code said this was the problem but know it still wont start same codes as before po 340 po335 po385 help please

Submariner409
04-02-08, 08:17 PM
PLEASE......Stop creating multiple codes for the same problem. Trying to keep up with you is like trying to stuff wet spaghetti up a wildcat's a$$. Put it all in one thread, and the world will come to your door. Really !!!

AJxtcman
04-02-08, 09:35 PM
just replaced camshaft sensor after car died on me code said this was the problem but know it still wont start same codes as before po 340 po335 po385 help please

You can run with out a cam sensor:yawn:

johnpage
04-02-08, 09:37 PM
on 4/1 my 2000 sts stalled on road got it towed home. check codes had a po 340 and a po335 . i replaced the crankshaft sensors 12/07. i replaced the camshaft sensor today 4/2 the car still wont start .the codes were cleared before i put the sensor in. still getting the same codes.

Ranger
04-02-08, 11:55 PM
P0335 - CKP Sensor A Circuit Performance

There are 2 crankshaft position sensors (CKP's), "A" & "B". They are located above the oil filter adapter which has to be removed to gain access. Replace them both.

johnpage
04-03-08, 10:03 AM
replaced them both 12/07 think there bad again?

Ranger
04-03-08, 11:40 AM
They shouldn't, but that DTC is very suspicious.

johnpage
04-03-08, 12:33 PM
going to get new ones talk to you later thanks .

Ranger
04-03-08, 03:58 PM
Be sure that they are A/C Delco.