: p0340 camshaft position sensor



pugel
03-31-08, 10:13 PM
2000 deville
replaced crankshaft position sensors 2 years ago
been getting p0340 for last year
starts and runs fine
looking for steps to replace camshaft position sensor
must be on this site somewhere but I can't find them

Submariner409
04-01-08, 08:09 AM
Unplug it (only one), take it out, install new sensor. No relearn procedures or PCM resets necessary.

Located on "front" (drive end) of rear cam cover, below and behind power steering pump. 1 bolt and short electrical connector.

It's in a location that is subject to road spray whipped by the serpentine belt, and maybe also subject to oil from a tiny weep in the front of the cam cover. You might get away with just an electrical connector cleaning.

loudes13
08-28-09, 11:35 PM
submariner, where exactly is the cam pos sensor? I removed the plastic engine cover and can't find it. The PS pump is closer to front bank than the rear.

This is on a '97 Eldo.

Allen
loudes13 at yahoo

Ranger
08-29-09, 10:45 AM
If memory serves me correctly it is on the back of the right head, close to the EGR valve and master cylinder.

Submariner409
08-29-09, 01:46 PM
Just below the front of the right (rear) cylinder head cam cover. Electrical connector and 10mm bolt into a retainer tab.

loudes13
08-30-09, 10:09 AM
thanx, it was unplugged. Glad I didn't need to get a wrench in there, it was a tight fit for my hand.

If anyone needs a CPS, let me know. You can have it for the cost of postage.