: No spark,Please help !!

03-31-08, 02:30 AM
I just finished changing engines in my car.The car cranks over but i have no spark.We looked over all the wire harness made sure everything was hooked up,before we set the body back down.it all looks to be conected.This is driving me crazy (HELP). I know there are many of you on here with alot of knowledge with northstars,i sure could some of it now.What are some of the things i can start checking?

03-31-08, 03:24 AM
No codes?

Well, you'll just have to trace it back. No spark at the spark plugs check for spark at the wire, no spark there check for spark at the coil packs (be careful they will shock you without hesitation if you give them the chance), no spark there then remove a coil pack and check for spark at the ICM, No spark there check the power source for the ICM (would give a code) as well as the camshaft position sensor.

roger greeb
03-31-08, 01:44 PM
dennis...roger here.,,,,i kinda like that last guys answer...still got the gas and the match here...i thought about what krsashed said after yr mail...no codes? mayb no spark equals no codes..but damn it man...surely u already been there...be careful wih those packs...ouch! ttyl good luck

03-31-08, 04:12 PM
def pull your codes
next borrow a scanner and check the paramaters with the engine on such as the TPS sensor....

03-31-08, 04:14 PM
I took the coil pack and ICM off my original engine and put in on the new engine and still no spark.

I was thinking,:thepan:I dont know if this would do it but with there being 2 crank sensors and i believe the same style plug that i could have them switched a to b, b to a could that give me no spark?

03-31-08, 04:15 PM
i dont THINK so
but its an easy fix to try switching them...

03-31-08, 04:55 PM
I thought the CKP sensors where made so that they could not be switched.

03-31-08, 05:14 PM
i would assume that too
but there isnt a special list on a crank A sensor and a crank B sensor on GM parts....
just a list for a crank sensor...

03-31-08, 05:34 PM
A and B are two different part numbers.

A is the lower, B is the upper. Different electrical connectors. Flats on sensor barrel are on different sides.

03-31-08, 05:42 PM
hey jay
I looked in my FSM and found conector end view, in engine controls components locator.
conector end view 8a-202-76 sensor A
conector end view 8a-202-76 sensor B

I also found this in an old post,
Ok, we put the new coil pack on it and found that we needed to reverse the wiring on the crankshaft sensor. After doing that, it fired right up but ran rough with a P074 and P053 codes. No other codes came up, we shut it down after a few seconds of running, and that's where we're at right now.

I really hope thats it,now i have to get to shop and check it,but the 3 lifts are tied up right now.


Hey sub just red your post guess that rules this one out.

04-01-08, 10:10 PM
Just a follow up on this thread, Last night I was reading in my FSM about CKP's (same plugs).crank sensor A top yel-ppl wires, crank sensor B bottom blk/wht-ltblu/wht wires.I got a chance to get it back up on the lift tonight and checked them they were switched.I switched them around and it fired right up.:thumbsup:

I just want to THANK all you guys for all your help.

This engine swap was not as bad as i expected.If you have the right tools and some patience you feel real good after it's done.

Thanks again,

03-13-10, 01:50 AM
My name is mark im having the same problem what kind of engine are yall talking about?

03-13-10, 12:14 PM

03-13-10, 03:32 PM

What year and model of cadillac?

03-13-10, 05:20 PM
Pre-2000 Northstars use the same CKP sensors in position A and B. 2000 and on use different sensors - in the new replacement DENSO series one is black, the other gray.

03-13-10, 09:25 PM
Pre-2000 Northstars use the same CKP sensors in position A and B. 2000 and on use different sensors - in the new replacement DENSO series one is black, the other gray.

There located on top of the oilfilter right?

03-13-10, 09:44 PM
4 inches above and to the driver's side of the oil filter adapter.