: Need help please!

03-21-08, 01:26 AM
Hey Guys
My 2002 Escalade has a problem while it is on idle. While I sit on the traffic light, it's RPM gauge goes up and down little bit also the dash lights goes up and down. I am guessing it's the idle speed motor. Can any one help me with this issue. I don't even know where to look for it under the hood. Also how to repair/replace it. I have done on Ford engine before. But on a caddy, it's all new to me. Thanks in advance.

03-24-08, 09:48 AM
Welcome to the Forum. :) How many miles since a tune up? Have you tried cleaning the T-Body?

03-24-08, 11:44 AM
Do s search on cleaning the throttle body. That's exactly how my 2003 was behaving and cleaning the TB and using a can of sea foam cleaned the idle right up.

03-24-08, 04:09 PM
sounds like good advice, if you have never cleaned the TB it is almost certain to be the problem. and when you clean it, look at the top left of the TB and you will see a small hole, that is where your idle air control gets its air, make sure you clean it out well.
is there a how-to anywhere on how to clean a TB on here? if not i can write one up, and get pics to. if someone will make it a sticky and wants me to im willing.

03-24-08, 04:42 PM
Make up a write up and I will make it a sticky, thank you

03-24-08, 07:11 PM
cool, ill start typing it up and next time i do one ill take pics, im putting my camera in my computer bag right now so i will have it at work!

03-25-08, 08:54 AM
Great make the post when you are done I will put it up top on a sticky. :)