: just bought an 02 escalade



friscoCADDY
03-19-08, 08:50 PM
Hi guys,

I just bought a 2002 escalade from my parents with 135,000 miles. I knew there were some problems with it when i bought it, but it dies at low speeds. After accelerating and them coming to a stop, the RPM's drop to about 100 and then it shuts of. Other than that it runs fine, we have brought it to a dealer and no codes were showing up for it. I have also put in a new fuel filter and fuel pump to no avail. Does anyone have any tips?

Also, I was wondering how involved putting a new upgraded sub where the stock on sits now., including a better amp.. any tips for that too? Thanks guys.

hcvone
03-20-08, 08:12 AM
Welcome to the Forum. Has the truck had a tune up? Try cleaning the T-Body, that could be the problem.

DLE
03-20-08, 01:00 PM
Congrats! As said above, try cleaning the Tbody. That should help it.

friscoCADDY
03-24-08, 07:21 PM
I haven't cleaned the TBody yet, is that an involved process or can it be done in my driveway with basic tools?

Synergetic
03-24-08, 08:46 PM
I haven't cleaned the TBody yet, is that an involved process or can it be done in my driveway with basic tools?

http://en.wikipedia.org/wiki/Throttle_body

http://www.popularmechanics.com/how_to_central/automotive/1272341.html

hcvone
03-25-08, 08:56 AM
I haven't cleaned the TBody yet, is that an involved process or can it be done in my driveway with basic tools?

One of the Caddy techs is doing a write up on how to do a t-body cleaning with pixs, it will be on the top of the page when it's complete. :)

friscoCADDY
03-28-08, 03:09 AM
thanks for the help guys!!

friscoCADDY
05-02-08, 02:05 AM
ok guys, im not going to lie but i was skeptical about the Tbody being the problem but one day decided to give it a try.. low and behold it is filthy so I purchased the snake to clean it.. and it my car runs like it was right off the show room floor!!!!!!!!!!!!!!!!!!! I can thank you guys enough if I could I would buy everyone a round of beer!! :alchi:

CHEERS!!
friscoCADDY