: 03 Heated seats turning off in seconds



dzr928
03-13-08, 11:36 AM
Newbie here... I use forums alot for this usefull bit of info, and its always a great place to get info. I've got an 03 escalade, 6.0 Awd, loaded up, nav blah blah whatever, anyway the heated seats in the front seem to have a conspiracy going against me. I turn em on, and in about 15-20 second they turn off, so i try again, then its 5 seconds, and they are off again, then its instant, as soon as the light kicks on, its off, and its the same on both front seats. I'm guessing a module of some sort, but does anyone have any info on this? The rear captians chairs work fine still, so i gues they are on a seperate module. I cant seem to find any info on this anywhere, so i know a forum would be the place to ask, so here i am.

deedubb
03-13-08, 12:51 PM
Same thing happens to me...but only with the front passenger seat. The other 3 are fine.

I'd like to know why also.

hcvone
03-13-08, 02:08 PM
I am pretty sure the 07's have a module under each front seat, not sure about the 02's to 06's, maybe Bill will chime in on this. :)

dzr928
03-14-08, 04:46 PM
ill be checking out the wiring this weekend for any pinch condition, and ill keep ya posted, but keep some answers flowing!

91sonomast
03-14-08, 09:11 PM
each seat has its own module, alot of the time the heaters/motors depending on if u have cooled seats die. But since both front seats do it, i would check for pinches or shorts to ground.
just read the other thread you posted in, sounds like you have 2 motors or more out, one in each seat, or both the modules crapped, or any combination of those. you need a multi-meter, a wiring diagram, and the ability to decipher a GM wiring schematic lol.

dzr928
03-24-08, 04:20 PM
sorry for the delay, i had a short notice work trip, and i still havent got around to looking under the seat, so i still gotta check out the wiring, but I'm out of town, and i wont be back until april 2nd... :rant2:

Anyway, this started all at once, one day they both worked, next day, they both didnt, so thats why in my head something tells me there must be a module that runs them both that took a shite...

I am an engineer, wiring diagrams make perfect sense to me! I have a multimeter & i know how to use it, so where can i find a wiring diagram and some schematics online for this seat system and module?

And it does not have cooled seats, just heated... Thanks again!