: Hey, all you guys, check radiator hoses



Crown Vic Owner
02-17-08, 12:56 AM
Always perfect to go looking everywhere for a coolant leak and finding this
http://img239.imageshack.us/img239/3460/dsc09626smallwn1.jpg
MAKE SURE THE HOSE IS ABOVE THE SHROUD

AJxtcman
02-17-08, 11:19 AM
Always perfect to go looking everywhere for a coolant leak and finding this
http://img239.imageshack.us/img239/3460/dsc09626smallwn1.jpg
MAKE SURE THE HOSE IS ABOVE THE SHROUD

THE HOSE DOES NOT GO ABOVE THE WATERPUMP BELT COVER!!!!!!!!!!!!

THE UPPER RAD HOSE ON YOUR SEVILLE IS HELD IN PLACE BY THE RADIATOR SIGHT SHEILD

Submariner409
02-17-08, 12:01 PM
AJ is correct: The "upper" hose leads forward of the water pump drive and up, and clips into the retainer lip molded into the radiator sight shield.

Click on the pic and scroll in...the hose enters the sight shield just this side of the yellow dipstick ring.

Crown Vic Owner
02-17-08, 12:52 PM
if i put it in the rad sight shield, it gets rubbed by the waterpump

AJxtcman
02-17-08, 02:49 PM
Interesting

Submariner409
02-17-08, 03:08 PM
Crown Vic, if your hose is the incorrect p/n, it has a bend which will get cut by the belt as it passes over the tensioner pulley. Look at the picture again. I just checked my upper hose and it's well clear of anything that moves when it is clipped into the sight shield channel.

AJxtcman
02-17-08, 03:17 PM
Seville and Deville hoses are run slightly different

Submariner409
02-17-08, 03:30 PM
Yeah, but his SLS hose is almost exactly the same shape as my STS unit. Went to Western Auto and pulled them both. (Gates catalog)