: 1996 Deville Troubleshoot update



orangeman
01-28-08, 10:13 AM
Took the deville to my mechanic. His read out came back first bank O2 sensor.
Took that out really dirty cleaned it put it back in.
Took out egr not sticking or really dirty so cleaned it anyway and put it back in.
Cleaned Idle control.
Cleaned air filter not really dirty either.
Added some injector cleaner.
When I left Emmisions light went off which is a good thing.
Got it home left it to idle.
Stopped after 10 minutes.
What was that throttle body cleaning you mentioned Ranger?

Submariner409
01-28-08, 11:10 AM
Try this: Google "cadillacforums.com+deville+throttlebody" and see what happens. If no joy, use the search function in the top ^^ bars as well as read the technical archive.

There is so much info on TB cleaning in here that you'll need a ream of paper to print it all out.

Ranger
01-28-08, 11:56 AM
As Sub said, check the Tech Tips section. I think there is a tutorial on how to clean it. If it is a '96 and has never been done, you'll be surprised at how filthy it is and will take some scrubbing. Doing it once a year will make it much easier. I do mine every spring.

orangeman
01-28-08, 12:17 PM
OK that's next I guess Thanks Guys for your help will let you know if that works

orangeman
01-31-08, 07:46 PM
OK throttle body cleaned no change except I have felt it surge at a stop once.

If the o2 sensor on the 1st bank was cleaned should it be hooked up again to see if any of the other o2 sensors register or should I just have them all cleaned anyway?

I just know this has to be something simple the car runs way too good. Maybe I should change the fuel filter also?

Ranger
01-31-08, 08:01 PM
I don't think O2 sensors are meant to be cleaned.

orangeman
02-01-08, 06:46 AM
So I guess I'll replace it..maybe I'll replace them all.. I'll let you know