: High idle/ IAC clicking?



madmathew
12-17-07, 11:06 PM
I got my used engine in and it sounds good except for idling at 1700 rpm and when I turn the ignition on without the engine running and after I shut it off the IAC motor is clicking for a minute. It has a code 52 also but from what i read thats not a problem or related.

Ranger
12-17-07, 11:34 PM
What year is it? Sounds like a bad ISC motor. That said, try adjusting it before replacing it. Do a search for ISC motor for the procedure.

Crown Vic Owner
12-17-07, 11:38 PM
Ranger, on this discussion, do our cars keep the TB open during idle, or do they just have a IAC where it feeds air behind the butterfly valve?

madmathew
12-18-07, 12:27 AM
I forgot to post that its a '95 vin 9 Eldorado. i cleaned the TB out while I had it apart and I noticed that the throttle was slightly open. I figured it would adjust itself once the car was running.

Ranger
12-18-07, 12:01 PM
Ranger, on this discussion, do our cars keep the TB open during idle, or do they just have a IAC where it feeds air behind the butterfly valve?

Earlier engines used an ISC motor to keep the throttle plate cracked open a bit to control idle speed (like the old carburetors). I think it was around '96 (give or take a year) when they went to the IAC valve to control idle with an idle air bypass circuit that leaves the throttle plate closed and bypasses air around it.

madmathew
12-18-07, 06:36 PM
i found the thread about adjusting the ISC but I could not get the motor to retract down. The destructions said you can push the plunger back down with your thumb and I even tried pushing it back with a screwdriver and it wouldn't go.

ewill3rd
12-18-07, 06:52 PM
The "nose switch" is probably bad in the ISC.
When the throttle is released it pushes the plunger in slightly, this closes a switch to tell the ECM that your foot is off the gas, the ISC holds the throttle open and reduces it slightly to help control idle speed and emissions.

Pretty common really. If I knew all the data tests on the HVAC display I could tell you how to check it but it has been far too long since I did one of those.
Based on what you have posted I would start shopping for an idle speed control motor.

madmathew
12-18-07, 10:56 PM
I have a spare from the engine I swapped out. I'll change it over tomorrow, thanks!

madmathew
12-26-07, 10:38 PM
Alright, I made some progress. I figured out that you need to prop the throttle plate open so the ISC plunger is not touching the throttle cam. Then turn the key on and then the switch is activated by pushing in the plunger and it retracts. Then I set the gap but it still idled high. I found a thread that discussed setting the base idle. I found that screw and adj. it back and got the idle down to 1000rpm. It seems to have an intake leak that is making it idle high also. It seems to be leaking where the vacuum hoses go into the top of the throttle body. I'm rigging this up with silicone to seal it. I left it drying for the night and I'll see how it is in the morning. This having 3 different things making the idle high has been kicking my butt!

ewill3rd
12-27-07, 08:30 AM
Sounds like you are on the right track.
Silicon is not a long term repair. See if you can replace any hoses that are cracked or damaged.
Vacuum leaks will definitely cause idle speed issues.

madmathew
12-27-07, 02:04 PM
Well, I found the vacuum leak. I used an engine from a 94 and my car is a 95. The intakes and gaskets are different but the gaskets for 95 lined up, I just had to tap 6 of the holes. What I didn't notice were the cuts that go into the intake ports that are not on the 95. It was making me crazy because I could hear a leak but I couldn't find it. I'm going to fill in the cuts and I'm confident I have it now. I will have to go back and adjust the idle but at least I got it solved.

madmathew
12-28-07, 01:12 PM
Well, I got it fixed up and it runs right now. Next is the code 76-force motor problem in the trans.