: 11.85 121mph Tick Tick Tick



stkshkr
11-10-07, 11:35 PM
Today was my last trip to the strip this year, best ET ever today 11.85 and best MPH ever 121.
Last pass I noticed the engine fell off a little on the top end and found that the belt was about to come off, fixed that and started it up to make another pass....Loud TICK TICK TICK, kinda sounded like a lifter but not sure. No codes...called it a day and drove it home, still not codes. Drives fine. Start trouble shooting, stethoscope sounds like it coming from Maggie but that can be deceiving.........So the teardown begins.
I always said if I opened up the engine I'd do everything right to make it rock solid, so the Winter project begins. I will no longer be able to say I have the worlds fastest stock motored V.

Note: Spun the Maggie with a drill and no sounds coming from her. Didn't really think that was the problem.

http://img2.putfile.com/thumb/11/31322591475.jpg (http://www.putfile.com/pic.php?img=7056657)


http://img2.putfile.com/thumb/11/31322591433.jpg (http://www.putfile.com/pic.php?img=7056658)

http://img2.putfile.com/thumb/11/31322591435.jpg (http://www.putfile.com/pic.php?img=7056659)

The Tony Show
11-11-07, 12:08 AM
You didn't happen to get a recording of the tick, did you?

Either way, let me know what you find. Mine's ticking like a time bomb (pun intended) and it's driving me nuts. Car drives great, no MILs, just a "chackachackachacka....."

stkshkr
11-11-07, 01:25 AM
Sounds like mine, quite loud. Pushrods, rockers and valves look good so far. Heads come off tomorrow.

Thoughts so far: New rods, Katech rod bolts, Shaft mounted rockers, springs and ti retainers.
Maybe... go 408 or bigger, pistons, heads or port the current ones, and who knows maybe go NA with cam etc. Work on the Tremac?
Gonna have to cage it I guess.

Naf
11-11-07, 01:28 AM
You runnin stock rockers?

How come, that is one of the first mods i would have done if i was lookin for serious power....

stkshkr
11-11-07, 01:50 AM
Yep, motor is all stock and worked well. Changing rocker ratios can have a negative effect on the cam and valve train geometry and I didn't want to get into that at the time

Tony,
Record your noise and I'll let you know.

rand49er
11-11-07, 06:48 AM
Geez, Gene, in my experience nine times out of ten, a tick tick tick sound is something in the valve train (lifter, pushrod, rocker, valve stem, etc). Did you change anything ... shift point? ... boost pressure? In any case, it'll be with great interest to watch your rebuild. :thumbsup:

BTW, congrats on your new personal best et/MPH! :highfive:

JonCR96Z
11-11-07, 09:28 AM
You runnin stock rockers?

How come, that is one of the first mods i would have done if i was lookin for serious power....

That all depends on what you mean by 'looking for serious power'.

If you are looking to gain power from the rocker arm itself by going to a bigger ratio, then you are just looking to waste money on some junk. A set of 1.8 rockers cost more than a cam and give nowhere near the power gain. They just aren't needed in LSx engines.

You really should upgrade to an aftermarket rocker of the same 1.7 ratio as stock, if you're going to be turning the engine more rpm. Due to the fact that stock rockers have a tendency to explode and throw needle bearings all over the place (which means they go through out the entire engine as they please).

Jon

CTSV05
11-11-07, 09:48 AM
Congrats Gene!!!!!!!!!!!!!!!!!

I was hopin to see a 70, but 121, wow!!!

Apparently those 4:10s havent hurt the mph any. Were you able to launch any harder?

stkshkr
11-11-07, 10:53 AM
Nope, still launching at 2000 RPM. Track conditions were improving when I left and I'm pretty sure it had a 70 in her. Had to remove the rear drag shocks as the car has still been hitting the A arms with the halfshafts. Stuck in a set of Monroe shocks and problem solved (rides better also).

stkshkr
11-11-07, 11:06 AM
Geez, Gene, in my experience nine times out of ten, a tick tick tick sound is something in the valve train (lifter, pushrod, rocker, valve stem, etc). Did you change anything ... shift point? ... boost pressure? In any case, it'll be with great interest to watch your rebuild. :thumbsup:

BTW, congrats on your new personal best et/MPH! :highfive:

No changes. It's very loud can't believe the knock sensors didn't put in limp mode. Wasn't smart enough to throw EFI live on it before I started the teardown. My first thought was a lifter.
Interesting side note, I have ARP header studs and retorque and visually inspect on occasion, yesterday I found the nuts on both rear studs missing and one other loose (no leaks).

Thanks, I was definately the crowd favorite yesterday.

The Tony Show
11-11-07, 11:26 AM
Sounds like it might have just been a blown header gasket or exhaust leak if two of your studs were loose/missing.

Chef
11-11-07, 11:39 AM
With 4.10 I'd expect a sweet 60'?

What was it?

Good job btw!

thebigjimsho
11-11-07, 01:44 PM
Damn nice garage!!!

Seattle CTS-V
11-11-07, 02:36 PM
Damn nice garage!!!


Yeah, floor matches the calipers!

stkshkr
11-11-07, 04:24 PM
Sounds like it might have just been a blown header gasket or exhaust leak if two of your studs were loose/missing.

No evidence of a leak and the sound is different

V-Love
11-11-07, 04:39 PM
.

Thoughts so far: New rods, Katech rod bolts, Shaft mounted rockers, springs and ti retainers.
Maybe... go 408 or bigger, pistons, heads or port the current ones, and who knows maybe go NA with cam etc. Work on the Tremac?
Gonna have to cage it I guess.

Another person that doesn't play around. Good luck!!!

stkshkr
11-11-07, 04:42 PM
With 4.10 I'd expect a sweet 60'?

What was it?

Good job btw!

1.71 not the best I've had, but the track conditions were not good, they were improving when I quit.