: Sts Running Terrible



theking1
11-03-07, 10:38 PM
2000 caddy sts 146,000
the car originally had DTC P0385 Crankshaft Position (CKP) Sensor B Circuit changed both crank shaft sensors but did not do the learn variance.stiil i am haveing the same issues rought idle and the car hard to start . check engine keeps coming back with DTC P0385 Crankshaft Position (CKP) Sensor B Circuit and another code DTC P0403 Exhaust Gas Recirculation (EGR) Solenoid Control Circuit what could the problem be the car is runnign bad any help would be appreciated.

Ranger
11-03-07, 11:02 PM
If the CKP sensor connectors where oily, spray them with Brakleen. Did you replace the "A" sensor with and "A" sensor and the "B" with a "B"?

Being that you are getting an EGR circuit problem, the valve is not likely the problem, but can't hurt to pull and clean it. Also check for a chafed or melted wire to it.

Submariner409
11-03-07, 11:20 PM
At 146kmiles it sounds like a general intake system cleaning is in order. This forum is full of throttlebody cleaning, PCV checks, intake manifold/crossover plenum replacement, general info.

To start, remove the engine dress cover and carefully unplug and plug every electrical connector you can see. From the p/s pump end all the way to the air cleaner. Drive. Same symptoms? Start cleaning. Pull the vacuum line off the FPR. Gas? Not good. Dry? OK.

Search......there are books written in here...........

AJxtcman
11-03-07, 11:28 PM
2000 caddy sts 146,000
the car originally had DTC P0385 Crankshaft Position (CKP) Sensor B Circuit changed both crank shaft sensors but did not do the learn variance.stiil i am haveing the same issues rought idle and the car hard to start . check engine keeps coming back with DTC P0385 Crankshaft Position (CKP) Sensor B Circuit and another code DTC P0403 Exhaust Gas Recirculation (EGR) Solenoid Control Circuit what could the problem be the car is runnign bad any help would be appreciated.

Check out the thrid posting.
It says more than just the Cranks sensors will set the Crank Sensor DTC's including an EGR problem.

AJxtcman
11-03-07, 11:36 PM
At 146kmiles it sounds like a general intake system cleaning is in order. This forum is full of throttlebody cleaning, PCV checks, intake manifold/crossover plenum replacement, general info.

To start, remove the engine dress cover and carefully unplug and plug every electrical connector you can see. From the p/s pump end all the way to the air cleaner. Drive. Same symptoms? Start cleaning. Pull the vacuum line off the FPR. Gas? Not good. Dry? OK.

Search......there are books written in here...........

This cover? It is dressed up
http://i224.photobucket.com/albums/dd25/AJxtcman/Fiero/1-1.jpg

theking1
11-05-07, 06:31 PM
replaced egr and cleaned throttle body still running bad long cranking when starting and when at a light can feel the car missing maybe bad crank sensors i got from autozone.i did no do the variance relearn or maybe bad pcm?please someone help.i hope i replace the crankshaft sensors in corect spot botom in black top is gray correct

Ranger
11-05-07, 07:28 PM
What is your fuel pressure? Do you hear the pump run at key on for 2-3 seconds? Have you checked the FPR for a leak?

theking1
11-06-07, 07:26 PM
38 to 42 fuel pressure no leak from fuel pressure reg

Ranger
11-06-07, 08:14 PM
Hmm, I think that is a tad on the low side, but not sure if it is low enough to cause a problem or not.