: traction control/stability



enyo
10-12-07, 10:22 PM
I recently had my nav radio changed and now when I switch driving modes my navigation does not confirm that T/C is off when I push it the first time. When I push it twice it does say competition mode and holding it down does turn off stability and traction (by the little light on the cluster).

Do the 07's or you guys who had your nav replaced have the same issue? Prior to the replacement my '06 would show that T/C was off if i pushed the button once.

I brought it up to the service manager at Cadillac and they said that that was normal for the new nav decks. I question it now because I was losing control on wet road today driving extremely carefully and couldn't get traction at very low speeds and began swaying.

Any chance that t/c is actually not working? Any safe way to test it?

Jon
10-12-07, 10:25 PM
Your new nav is a CTS nav, not a CTS-V nav.

I can't remember if they can just change the program or if a whole new nav needs to be put in.

CTSV_Rob
10-12-07, 10:27 PM
Welcome to the Dealers that know next to nothing.

I have an 07 and it works the way it's supposed to.

Like Jon, I'm not sure but I believe they can just reprogram the nav unit. The hard part will be convincing your dealership though.

enyo
10-12-07, 10:30 PM
yup you're right - because when i got the deck it was programmed for the CTS buttons and all my buttons were messed up. They reflashed my deck for the right buttons...

...interesting.

I'll take it in Monday. They broke my shift boot too checking my shift gates!

:rant2:

The Tony Show
10-12-07, 10:51 PM
Reprogram will fix it- the V uses the same Nav unit as a base CTS, just a different flash.

rand49er
10-12-07, 11:17 PM
Reprogram will fix it- the V uses the same Nav unit as a base CTS, just a different flash.Tony, you're great! It is so-o-o nice having someone like you (and a couple others) who really know this stuff here to help. Points for you!

Jon
10-12-07, 11:19 PM
Reprogram will fix it- the V uses the same Nav unit as a base CTS, just a different flash.
You da man!

The Tony Show
10-12-07, 11:24 PM
No problemo. :thumbsup:

GM_Tech
10-13-07, 09:12 AM
There is a Preliminary information on this (it's like a TSB), the number is : PIC4021.

If you have any trouble at the dealer tell them that, they should understand.

It's saying : "If the concern only occurred after a Navigation Radio replacement, ensure that the Radio Set Up procedure was performed using the Tech 2. When performing the Set Up procedure, it is important to build the vehicle as a product series DN (CTS-V) on the Tech 2. "