: Oil Temperature Warning Message



christmas
10-05-07, 09:40 AM
OK....I am not sure what is going on with my 04 - CTS-V.

Last week while driving to work my Oil Temp Warning light came on as I was driving to work. Temp got as high as 310. I called the dealer when I came to work and he told me to come in for them to take a look. Since the car wasn't giving the warning at the time when I drove in they plugged in the car to see if any issues came up from the computer. (NOTHING SHOWED)

Since then I have had this pop up on me saying the oil temp is 285 flash the warning message then go back to 257 the next second.

I was thinking this was due to the fact that I might need to change my oil, but that is at 60%. Then I was thinking that I might have lost oil and need to put more in, but that isn't the case either.

The oil warning light comes on if I am on the road for 10 minutes in stop and go or if I am going 70 miles an hour for 30 minutes. I am not sure what might be wrong, so I hope someone here might have a clue for me.

The Tony Show
10-05-07, 10:21 AM
It's a well documented issue- either the computer needs to be reprogrammed, or you have a bad ground on the oil temp sensor.

Most of these issues have been discussed to death, so try the "search this forum" button on the top right next time before going to the Dealer.

LV_V
10-05-07, 05:46 PM
My car is at the dealer right now and this is one of the items on my laundry list as well (mine has been up to 330ish). I will know for sure if they fixed once I get the car back, but people have reported previously that it is a) a bad ground from the sensor or b) the instrument panel cluster needs to be reprogrammed.

Good luck. I will report back when I get the V back and put a few miles on it.

christmas
10-17-07, 07:21 AM
OK... I took my car in to the dealer for the 2nd time in a week to have them re-program the car. I was told that the first time "it didn't take".

Now I am driving it and the temp shows 305 before the warning light comes on.:banghead: I was thinking that they did something to the warning light to turn it off, but then it started it's flashing all over again.

Anyone have any suggestions on how to get the DEALER to fix this issue? I have taken in to him everything from past posts to show him what to work on and what to fix, but it seems that after 2 try's and nothing is fixed I am guessing that they still have no clue.

HELP PLEASE!!!!!

CIWS
10-17-07, 08:47 AM
Usually what we recommend when an owner can't seem to get satisfaction from a dealer is to ask around and take it to a different one. If there's more than one Cadi dealer in your area ?


edit- There are several Houston owners on this board, they should be able to point you to one down there they know of.

theloanman219
10-17-07, 10:03 AM
There is a IPC out for 2005MY

The document # is 1972141

Subject: Engine Oil Temperature Reads High Or False Warning Message - keywords DIC display gauge IPC #PIC4508 - (05/15/2007)

Models: 2005 Cadillac CTS-V

Condition/Concern:
Some customers may comment the engine oil temperature rises very quickly and remains high when they are not driving on long hills or performing aggressive maneuvers. In some cases the Oil Temperature Warning Message is displayed.


Should be the same for 04