: P094 limp mode, no overdrive



d_pope
10-04-07, 06:20 PM
I have a 1994 Cadillac sts 4.6 Northstar engine with P094 code. I have 1st, 2nd and 3rd gears but when it is time to shift into overdrive (45 mph)the car goes into limp mode. I have just replaced the PCM, TPS and the A and B solenoids with filter and bracket.

I cleared the codes using the climate control and recalibrated the throttle. Have taken the car for a test drive and I still have the same problem. No overdrive at 45. I stopped and turn the car off, Restarted and drove the car back in 3rd. Car shifts 1st, 2nd and 3rd and reaches speed over 45mph.

The codes that are displayed now are

P036 = EGR pintle out of range. Current

S072 = Left Rear accelerator fault. Current

P094 = shift "A" solenoid problem. History (was current but I restarted the car to get it back home)

Can the P036 pintle out of range or the S072 rear acelerator cause the transmission / PCM to enter limp mode?

Has anyone had the same problem after replacing the solenoids and what did you do to resolve it?

I have seen a few posts about this situation but no final solution.

Any input would be greatly appreciated.


Thanks,
Dave

d_pope
10-07-07, 10:25 AM
Follow up on this problem 10-7-07.
On the advice of a fellow caddy owner I have cleaned the EGR valve and removed the intake plenum to clean the passages that lead to the EGR valve. There was a lot of carbon build up in the passages that are under the intake plenum/manifold. The EGR was stuck closed the pintle should move freely and I used a screw driver to push it back from the seat. I then scraped the carbon deposits from the seat area.

I clearded all codes and test drove the car. On the back roads the transmission shifted 1st , 2nd ,third and fourth. This is the first time in weeks that I have had overdrive! With more driving the car did go into limp mode. Checking codes I now have P094 and S072. The P036 code (EGR pintle out of range) has gone due to the cleaning.

I feel that the next step is to tackle the S072 code and replace / repair the left rear accelerator. Since the two codes are being triggered at the same time.

Ranger
10-07-07, 01:14 PM
left rear accelerator? :hmm:

dkozloski
10-07-07, 01:40 PM
left rear accelerator? :hmm:
It's right above the dingfod.