: 4.0 Northstar No Start PLEASE HELP!!!



Cedarblues
09-18-07, 11:32 AM
This is a long story, but the whole story!!! Bought a 1995 Olds Aurora with the 4.0 Northstar in June with 155k, after 1 week, noticed a fuel leak in the fuel return line, which my husband did a temp fix so I could drive her, after 2 months of fighting the dealer/Olds is agreeing to repair. So I was getting ready to take to dealer to get the repair done and I was going to work one day after driving home in a heavy rain the night before. I started car and went inside for a minute came out and it was running very rough, I shut her down for a minute and tried again, same thing, called the hubby and started again, it stalled and backfired a tad. At this point we're convinced it's the fuel pump even though we can hear it coming on. (About a week before Oil Pressure Switch was ghosting and my fuel pump stayed on and drained the battery, changed OPS and fixed this problem, so we assumed it burnt up the pump.) Changed fuel filter, oil and filter when OPS was changed. So I ordered a fuel pump kit, while waiting for it to arrive we bought a fuel pressure gauge and it appears OK, reading 40-48. So from there we changed spark plugs and checked for spark, replaced both Crank Position Sensor's, had the ICM tested it was OK, but did swap it out with one w/ coils I purchased on ebay, seemed to want to start a little more, but still no go. Changed the air filter (it was FILTHY). Trying to avoid having it towed to get it scanned for codes, but getting frustrated at this point after 3 weeks! Any more suggestions? Thanks

DevilleMN
09-19-07, 02:46 PM
I was going to work one day after driving home in a heavy rain the night before. I started car and went inside for a minute came out and it was running very rough.......it stalled and backfired a tad.

There is the clue!

Have you checked wiring harness connections, plug-in connectors, ground straps and fuses.

Good luck!

clarkz71
09-20-07, 08:11 AM
This is a long story, but the whole story!!! Bought a 1995 Olds Aurora with the 4.0 Northstar in June with 155k, after 1 week, noticed a fuel leak in the fuel return line, which my husband did a temp fix so I could drive her,

Are you aware of the recall for the fuel rail & return line on your car?
Did the dealer check your VIN to see if it was done? It's a free repair.

Cedarblues
09-21-07, 11:31 PM
Finally tracked down the dealership that did original recall work. They replaced the fuel rail but not the lines. They claim they now will replace lines. Still trying to get the damn thing running. I bought some fuel inj noid lights today. We will see!!!! Later