: 68 deville headlights,brake lights stopped working



nixon186
08-26-07, 11:04 AM
i went to turn on my headlights on my 68 sedan deville last night and only the parking lights came on. i also noticed my brake lights don't work(the rear parking lights do however).i checked fuses and found nothing. i'm thinking i have a bad ground somewhere. any ideas?thanks.

Junkman
08-26-07, 06:28 PM
Could be a bad ground or a bad headlamp switch. Try depressing the high beam switch a few times and see it that gets the headlamps working. The brake lights are separate from the headlamp circuit, so I think there is more than one problem to be resolved. Usually a bad ground will manifest itself with only the front or rear half of the car, not both. Check the ground wire from the battery to the engine block and the smaller ground wires that tie the body panels to each other. They are usually small flat woven copper wires. I believe that this is going to be one elusive chase until you find the culprit. Cars that are seldom used, develop more electrical problems because of moisture than any other reason.

nixon186
08-26-07, 06:36 PM
i figured the brake lights and headlights were on different circuits but it struck me funny that they both stopped working simultaneously. it had only been 4 days since i drove the car last. the car is only driven once a week for maybe 20 miles so it does sit alot.

cadillacmike68
09-01-07, 11:31 PM
Check your foot dimmer switch. mine went bad and the headlights power routes through this switch!