: Tranny Problems Uh Oh



partyharty
08-25-07, 04:33 AM
Hello everyone,

I have an 83 cadillac deville and I have noticed a problem. When driving the transmission is not shifting out of 3rd like it should. It feels like it is slipping but only between 3rd and 4th. The rest of the gears shift as normal.

We had the fluid changed fairly recently and the shop said the fluid was dirty but it did not smell burnt, the fluid looks good. The shifting problem came on really quickly. (as in one day it was fine and the next it wasnt)

So the question is, is there anyway that this is something other than a major transmisson problem? Could it be a sensor of some sort (and what is the best way to troubleshoot).

Car has approx 70,000 miles on it and it sat up for approx 10 years before we got ahold of it.

Thanks,
Chris

Gwokable
08-26-07, 11:29 AM
Check the torque converter lockup solenoid.

partyharty
09-01-07, 09:03 AM
I have a pretty good idea where it is but how do you test it? Is it just one of the parts you replace to see if it works out (autozone shows it being a $20 or so part)?

Thanks for the response.

Chris

Gwokable
09-01-07, 03:15 PM
You can check the solenoid by bringing the car above 50MPH and tapping on the brake pedal. It'll cause the car to feel like it's shifting but it isn't. The solenoid can go and will wreak havok when it does depending on what goes.

Check your Throttle Valve Cable, it's on the carburetor near the throttle. If this came disconnected there's a good chance the trans is fried. Physically make sure it's connected and you can pull it back with your finger and it goes back to being straight.

If the engine is setting codes for TPS/MCS, that can cause the trans to do some weird shit as well like cause the torque converter to unlock while accelerating at 60 or 70MPH causing the car to rumble.

Finally, take it to a trans shop and have them pressure test it. If a clutch went or a gear shattered, they'll be able to tell there.