: Chevy 350 Experts - ID this connector??

07-08-07, 07:28 PM
Noticed while I was cleaning out the new Caprice that there appears to be a disengaged wire just forward of the washer fluid bottle. I'd bet that the connector and the plug go together, but with my luck I'd plug it in there and the battery would explode...

Anyone familiar enough to know that they do indeed go together?


07-08-07, 09:56 PM
If the pins match and the locks match, I'd plug then together. They sure look like they mate.

07-08-07, 09:57 PM
Looks like it's for the flux capacitor.

07-08-07, 10:39 PM
Looks like it's for the flux capacitor.

That's kinda what I was thinking. The onboard flux capacitor is down for repairs at the moment - it seems the ambhelical hex nut worked loose from the marselvane trim oscillator, and because the hex nut is reverse threaded, every time I tried to tighten it up it loosened a bit more. Finally I got it tight enough to come off (or was it loose enough to stay put?) but then the anti-whiplash frammistat pin fell out of my hand and lodged somewhere in the bowels of the exhaust manifold bracket.

I'll give it a shot.. :)

07-08-07, 10:41 PM
Man that could be anything on a SBC. It looks like it goes into the fender well.
Older SBCs have a lot of two prong conectors. Did you trace the wire?

07-09-07, 09:50 AM
Looks like some sort of lite connection

07-09-07, 07:46 PM
Well, they don't fit together anyway..the male one comes out of the same wire wrapped loom that goes to the pumps for the windshield washer but who knows where it comes from. The female connect has two holes, but is larger than the male piece, and both ends have a plastic divider between the electrical connectors, so they don't go together.

I guess I won't know until something doesn't work, and so far, everything works....

Maybe a "low fluid" indicator lamp for the w/washer fluid????

07-09-07, 08:07 PM
It's either for that electronic turbo or for the blinker fluid pump.

07-09-07, 08:07 PM
yeah those connctors wont go the wire colors are diffrent ...

used cars and strange wires ....kinda goes hand in hand ....many hack job mechanics touch these cars that dont have a right to ...i imagine thats where the problem is ...

07-09-07, 09:27 PM
The male connector looks like the coolant temp sensor pluig I had on my 91 Vette.

07-09-07, 11:33 PM
I'll check my 92 RMS tomorrow and see if I can figure out what it might be

07-10-07, 12:47 AM
Some muffler bearings had an electronic impulse generator. Try google.com