: Another coolant/radiator/headgasket question



pimpdaddycaddy91
06-24-07, 11:52 PM
So over the last couple of months I know I had a small coolant leak and I discovered the upper small hose on the surge tank was loose and the tank was cracked so I replaced the tank, clamps and cap and I took the opportunity to flush my radiator for preventative maintenance since I hadnt done it before. (99 ETC 110,000 miles I bought it with 82,000).

I knew it was over due so I used a flush cleaner made by prestone and ran it for a day and a half and then put clean water in and then my problems started. Now I drive it for 10 miles or so and it starts getting hot and will eventually overheat. I found that it is leaking water from the overflow, so I replaced the thermostat and no change. ( I tested both thermos in a pot of boiling water and both worked). I used a combustion tester myself on the cap and it showed no results.

So my question is did I screw something up with flushing? Why did this problem start just as I flushed it? What else could cause high pressure in the cooling system if there is no exaust gasses? Previously I had no problems and I drove it 50+miles a day. I'm at my wits end.

I would just like some more ideas before taking it to a shop to have better tests done to rule out a headgasket.

Ranger
06-25-07, 12:25 AM
You may well have loosened some crud that clogged the purge line. Check it. If you don't know what or where it is, do a search for it.

tpis15
06-25-07, 08:47 AM
The system could be airlocked, you may have to "burp" it.

pimpdaddycaddy91
10-17-07, 12:33 PM
Well Ive had my Eldo sitting for awhile and I decided to take it to the dealer to see if they could figure it out. I first spent about $400 because they said it was the water pump. Well no change. So I took it back and spent another $100. They said they pressure tested the radiator and that it never showed any increase of pressure which led them to believe that it wasnt a head gasket but they said the cap was bad. So they replaced the cap even though I had already done that and still no change.

Now it starts a little rough but smooths out and drives just fine it just loses coolant out the overflow.
I have checked the purge line twice and it is good and now I notice quite a bit of steamy white smoke out of the exhaust.
So I think that it is a head gasket but the dealer said they "didn't think so" but I haven't been back since the last time they worked on it.

My question is does anybody think it could be anything else? If it is a headgasket would I be better of fixing this one or buying a remanufactured engine and from where? I am very mechanical myself. I have rebuilt engines and trannys in the past but have never torn into a Northstar. Its just that I figure that if Im going to pull the engine to do the HGs I might as well do the whole engine with it having 110,000 miles. What do you think?

Ranger
10-17-07, 05:04 PM
Now it starts a little rough but smooths out and drives just fine it just loses coolant out the overflow.
It is almost certainly a head gasket with those symptoms. If you are going to drop the drivetrain yourself, you may as well Timesert it and replace the head gaskets.

Mark C
10-17-07, 08:45 PM
If you pull it, just do the head gaskets and inserts, don't dig any deeper into the engine than you need to. I just finished mine last month and when I took the heads off, there was no wear in the cylinder walls at all, no ridge of anykind, even the original honing marks in the cylinder walls were plain as day. Mine had 116K on it. Costs can quickly get out of hand if you start pulling stuff apart just because you have the engine out. Unless you have other issues with the engine stick to the head gaskets, and maybe valve seals and new valve cover and water pump crossover gaskets. Check your heater pipes on the back of the engine closely, one of mine was corroded right thru on the back passenger side of the engine at one of the bends. It didn't leak until I tugged on the heater hoses to disconnect the engine from the firewall.

misfit6794
10-18-07, 11:54 AM
The system could be airlocked, you may have to "burp" it.

The n* is self purging of air.

It definetly sounds like a headgasket. Especially with the rough idle and the fact that you've replaced nearly every other part of the cooling system, thats usually the biggest symptom.

A northstar isn't your typical engine, but since you have some experience you definetly could attempt it yourself. The biggest pain in the ass with the hg's is that you have to drop the whole front subframe out of the car, so if you don't have a lift its a bitch. If you manage to get the engine out you need to rethread all 20 headbolt threads in the block with timeserts, alot of fun. There's a good reason mechanics charge between 2500-3500 to do it.

pimpdaddycaddy91
10-18-07, 01:51 PM
Thanks for the replys and info. I know I'll have to drop the whole engine and I'm sure I can handle that I just want to do some more research on performing the timeserts. I don't know when I can get started on it but if I don't have to rebuild the whole engine, just the HGs and timeserts I'll stick to that.

misfit6794
10-18-07, 06:42 PM
You shouldn't need to rebuild it, once you get the heads off just take a good look at the heads for any warping or cracking from overheating, usually not the case. There's a ton of info on this site, several members have done the hg's themselves.

zonie77
10-18-07, 10:39 PM
Here's some info.

http://www.cadillacforums.com/forums/northstar-performance-technical-discussion/5052-n-head-gasket-repair-part-i.html

There's been quite a few guys doing this at home. It's a long job but not rocket science. There was a guy on recently that's been doing these in a one car garage.

SpiritF4
11-06-07, 04:43 PM
Has anyone tried K&W block sealant?

Ranger
11-06-07, 06:00 PM
Snake oil. Repairs in a bottle do not work.