: 98 STS spewed coolant...



PhxCowboy
04-06-04, 03:04 AM
:annoyed:

My 98 STS spewed its cooloant all over the driveway this evening. Its even a relatively cool night in Phoenix, AZ. The temp guage did not go up more than one bar over the normal mid-point, any ideas? Also, if this is more than my limited abilities can handle, anyone recommend a service shop in the Phoenix area other than my local dealers?

Thanks,

Jack Addington

Ultra Slow
04-06-04, 04:26 AM
If you have about 60-70K on it, it is probably time for a water pump. When these go out, many times they do not leak, but get weak and just do not circulate water good, causing the car to get hot then spewing water out of the overflow.... The second thing is the cooling fan(s) Start the car... Turn the AC on, and within a minute, both should be spinning... If not, check each one out, then fuses and relays.... Be carefull and get this problem solved as fast as you can before it gets too hot........ Even though the Northstar is "supposed" to be able to run without coolant.... I have seen more warped heads, blown gaskets on these engines over any push rod V8 ever due to low coolant conditions.....

My Cadillac Site (http://www.mcsmk8.com/cadillacs/mycads.htm)



:annoyed:

My 98 STS spewed its cooloant all over the driveway this evening. Its even a relatively cool night in Phoenix, AZ. The temp guage did not go up more than one bar over the normal mid-point, any ideas? Also, if this is more than my limited abilities can handle, anyone recommend a service shop in the Phoenix area other than my local dealers?

Thanks,

Jack Addington

PhxCowboy
04-06-04, 11:08 AM
:banghead:

Thanks for the input. It's now done it twice, I got the system refilled, and all appeared to be happy, fans spinning and all... for about 12 minutes... then puked it all out again, again without overheating. It is coming out the overflow line, under the passenger side of the radiator, nice steady stream... ugh!

airbalancer
04-06-04, 01:47 PM
your water pump went at about 59000 miles, fixed under extended warrenty

zonie77
04-06-04, 08:11 PM
There are some threads around about checking the cooling. There are tests for checking the head gaskets. How handy are you? Do you want to do some of it yourself?

growe3
04-06-04, 08:27 PM
:banghead:

Thanks for the input. It's now done it twice, I got the system refilled, and all appeared to be happy, fans spinning and all... for about 12 minutes... then puked it all out again, again without overheating. It is coming out the overflow line, under the passenger side of the radiator, nice steady stream... ugh!
If it is overflowing without apprently over heating, try replacing the surge tank cap. I think the Stant cap is a #11230.

-George

PhxCowboy
04-08-04, 06:45 PM
Diagnosis = radiator. Finally got it in the shop, heads, cap and water pump, all OK. Still not cheap, its gonna be about $1K, parts and labor.

Thanks everyone for input, I'm not as handy as this problem required...

:helpless:

zonie77
04-09-04, 12:36 AM
Your symptoms don't sound like a radiator.
It doesn't gradually overheat but suddenly spews coolant??

speedyman_2
04-11-04, 12:14 AM
Just to let everyone know. I had the upper radiator hose blow. But, not because of overheating or normal wear. On my '98 STS I know that the plastic cover that you have to remove to get to the headlights holds the hose away from the Cam gears. I had some new lights put in and the mechanic forgot to route the hose back through that plastic. The gear ate away at the hose and then you know what happened from there. I was so mad. :rant2: Anyways, just wanted to say that in case anyone is ever going to remove that piece. And, glad to hear you fixed your problem too.