: 02 w/ interior switch illumination problems



ZX_man
06-08-07, 03:51 PM
I currently have 3 seperate switch light issues. The volume/mute button are no longer illumiated. I did a search and found the write up for replacing those.

My second issue is the window control on the driver side. The driver/passenger window switch, mirror adjustment pad and selector are not lighting up now. The rear window control on the driver side are good. So pretty much just 1/2 of the driver control area has no light. Ideas? I have not taken it out yet, are they seperate units or combo?

I also noticed that the cup holder and ashtray lights are out too. :rant2:

I'll recheck the fuses again, but they all checked out last time I put a test light on them. Small issues....but you know how that goes.

BTW- Just replaced the water pump a few weeks ago, it had been leaking coolant over time so I bit the bullet and changed it out. The dealer wanted almost $300 for it!! Went to Autozone and picked one up for $130 out the door. There is no core charge due to the impeller assembly being a pressed unit. Really can't complain, the stock unit lasted 120K.

TIA

Walter

erf2u
06-08-07, 04:41 PM
yeah, i got the same issues with my 02 as well. Seems like I have several more lights (about a dozen) that are out on mine. Some are intermittent.

I thought about bringing it in, but since the switches actually still function, have not got the time to. To be honest, it bothers me less and less everyday.......

fast66
06-09-07, 09:17 AM
So many of my lights have gone out that I have forgotten what was lit up in the first place.

Playdrv4me
06-10-07, 01:13 AM
Yea same with my 03. Its shit like this that gives domestic cars such a bad reputation. Why the hell did they use INCANDESCENT bulbs in places where white or blue LED's would have functioned perfectly?! Makes no sense whatsoever. 07 uses blue LED lighting.

Doesnt bother me anymore though.