: HELP!!! my eldorados crazy.



1993 eldorado green1
04-05-04, 09:55 PM
well first of all im new to this cool site, but i`ve been reading this forum for days, i have already learned alot from u guys, thank you for that. well my car is a 1993 eldorado with the famous n* and i just did some work on it today, and the outcome is looking bad, well first of all she ran pretty good except for the poor gas miledge, and odd smell from the motor when stopped at a light, after reading these pages i decided to kleen the pholnic spacers of carbon and let me say there was alot! i reapired small cracks with rtv, and used a shop vac to make sure everything was clean, i should say that im a tech in the automotive field but not farmiler with the northstar, anyway after reassembly and start up it now starts up and revs to about 2500 rpm then idles down to like 1300 and stays there, it used to idle at 700, also the gas milege is worse, and there is a sever lack of power but i checked for codes and found none present? but i did find that the awful smell was from the pcv valve laying out of the head, i replaced it and put it back where it`s suppost to be and the smells gone, what does this sound like i may have done wrong? i need help with this one asap, it`s my only driver, thanks for any help and i`ll be checking in here often, thank you.:hmm:

Chuck C
04-05-04, 10:00 PM
perhaps it's a stuck EGR valve?

Lawrence
04-05-04, 10:06 PM
I would guess you have a vacume leak.

Did you clean the throttle body? If not I would try that first.

1993 eldorado green1
04-05-04, 10:30 PM
yes i cleaned the throttle body, and wouldnt the egr throw a code?

ThomasO
04-05-04, 11:09 PM
First thing that came to mind is something bBob said awhile back:
http://www.cadillacforums.com/forums/showpost.php?p=76881&postcount=3

If that doesn't help, type "fast idle" into the search thing and you will see a lot of other answers to this problem, but it sounds to me bBob was on to a cure for you

Lawrence
04-06-04, 02:14 PM
yes i cleaned the throttle body, and wouldnt the egr throw a code?
Yes

Lawrence
04-06-04, 02:21 PM
Pull the rubber boot from the Tb and make sure the butterfly is closing tight while running. And that the linkage is free. If not find out why. If these are OK, I would take it back down to check your work. Looking for a vacume leak. And while there install new intake gaskets.