: Cruise Control



EGSJR
05-18-07, 03:17 PM
Have 1200 miles on an '07, love the car, no complaints until cruise control quit yesterday........anyone had this problem or am I the only lucky one so far?

c5 rv
05-18-07, 07:26 PM
Not to be a smart aleck, but did you you accidently turn off the cruise control switch on the turn signal stalk? Don't laugh, folks who aren't familiar with GM cars forget about this.

EGSJR
05-21-07, 07:02 AM
Well, judging by my typing, I can see the validity of the question...but have had several GM vehicles....that is not it....taking it to the shop this am, first time have ever had this problem with a GM car, probably a fuse, but something would have to cause it to blow....

leeclapp
05-21-07, 07:35 AM
Have 1200 miles on an '07, love the car, no complaints until cruise control quit yesterday........anyone had this problem or am I the only lucky one so far?

I have an 07 SRX sport and the cruise has gone out twice now---once for two weeks while on a trip and then again yesterday---dealer unable to find culprit...OnStar diagnosed transmission trouble...dealer said no problem..Lee

EGSJR
05-21-07, 01:50 PM
Now that you mention it, same day it went out, I noticed the trans seemed to slip into neutral one time while idling, only the one time, but same day.....will see what the dealer says but will mention this to him also.
Thanks

john d
05-21-07, 02:51 PM
Years ago had a stick stift with cruise control. Discovered accidently that if the cruise speed was set and the clutch was disengaged/depressed so to allow the speed to decrease the engine throttle would progressively open wider in an effort to maintain the crusie set speed.
Is the SRX cruise electronics programmed to defeat this kind of engine runaway?
If so, maybe a tranny position switch sensor is out of adjustment to the extent that if the sensor is misadjusted to a netural side bias the cruise siginals are defeated.
Interesting issue....inquiring minds want to know.

EGSJR
05-21-07, 04:56 PM
I did pass on the transmission info to the dealer, should get it back late today or tomorrow, will post the findings should this become a problem for anyone else. Other than that, thoroughly pleased with the car.

c5 rv
05-21-07, 07:38 PM
I hope your response from the dealer isn't the dreaded "Could not duplicate problem."

EGSJR
05-23-07, 05:09 PM
Well,
Got it back. I went by the dealer yesterday after reading the post on OnStar showing a transmission problem, ran mine, same thing. The dealer checked everything out, re-set some things, cruise now works. But, he was honest and said they could not find the cause. If it goes out again, they are to have an engineer come and see what is wrong....they were honest about it and I cannot complain about the service I have had in the past nor this one....this might be something to watch for in the future.....

gdavidov
05-30-07, 05:58 PM
I bought a new 2007 SRX in April. I tried engaging cruise control the 2nd day I had it and it wouldn't engage. I had a GM car previously, so I know I was setting it correctly. Left a message with the dealer and of course the day he called me I had already tried it again and it worked. I haven't had an issue since. Not sure what happened then, but I'm not surprised to hear of someone else having an issue.

On a side note, I also have a problem where I can't reset the exit seat location. It's been driving me nuts. If anyone's heard of that problem, let me know.