: Rough Running, Stalling.....



DopeStar 156
04-08-07, 09:27 PM
My car lately has been stalling after start up, and running rough at red lights at a near stall state. It has no preference of temperature as it does it hot or cold. What do i need to check/replace to fix this annoyance?

N0DIH
04-08-07, 09:56 PM
Look for cracked/broken vacuum lines. PCV is a good one to get hard and crack. Look at all lines under the front/back that go into the baseplate. I am assuming no check engine light. A spray bottle with soap and water in it is helpful to find leaks. Propane torch better. Look for idle change.

Carb is spec'd to be retorqued to intake every 6 months. I haven't found a soul to do it. 10 lb/ft's last I checked, but double check. You can easily damage a carb by overtorquing.

Is cap/rotor in good shape? My 307/350 always seemed to be sensitive to the cap/rotor getting crud on the contacts. I pulled the cap/rotor out and polished up the contacts every 15-25K or so. It always ran great when I did that.

Also look carefully at the cap indexing. I noticed on mine when I would bump up timing it would start to idle rough and it was the ECM that kept timing up so high at idle that the timing would be starting to get off the edge of the contacts. So I installed cap/rotor, drew a paint pen line to line up stock index, then cut off the notch inside the cap to remove the index, and then moved the cap index position to it would recenter the cap/rotor with the contacts. I moved it probably 3/16". It helped a LOT in idle and cap longevity. Only computer controlled engines seemed more sensitive to this.

I~LUV~Caddys8792
04-09-07, 02:06 PM
I bet this has something to do with it sitting in storage so much.....


Forget the Blazer! Use this as your daily driver!!! :D

DopeStar 156
04-10-07, 03:08 PM
Yeah, then I can sell it as scrap metal in say, a year....