: Which codes....?



The Director
04-07-07, 09:55 PM
I pulled these codes from a 93 STS:

P085
A011
TO33
S038

Which one of these would turn on the "service engine soon" light. I need to get inspection and want to get rid of that light message.

Any suggestions??

Ranger
04-07-07, 10:06 PM
P085 (E085) ........................................... Idle Throttle Angle Too High (Will illuminate the MIL)

A011 .......................................... High Side Temperature Sensor Circuit (A/C System - won't illuminate the MIL)

T033 ........................................ RR Wheel Speed Sensor Continuity Fault (Won't illuminate the MIL, will illuminate the ABS light)

S038 ................... Electronic Level Control Exhaust Valve Short to Ground/Open (Won't illuminate the MIL)

The Director
04-08-07, 07:26 AM
p085- how do I fix this.

I need to get rid of the "service engine soon" light.

Ranger
04-08-07, 11:07 AM
I'd start by cleaning the TB. It may sticking and not closing the throttle plate all the way. Does it idle high? If that does not help, you may need to R & R the TPS, then clear the codes.

fubar569
04-08-07, 12:03 PM
I'd start by cleaning the TB. It may sticking and not closing the throttle plate all the way. Does it idle high? If that does not help, you may need to R & R the TPS, then clear the codes.


:yeah: thats where id start

The Director
04-10-07, 11:59 PM
Okay........I cleaned the throttle body and the P085 code is still on. I'm going to clean or replace the TPS tomorrow. Is there any procedure to adjust the TPS after removing and replacing it??

The Director
04-11-07, 12:06 AM
BTW...I noticed the throttle blade didn't close all the way (just slightly open.....and really mean slightly, like a small crack). Is it suppose be at an exact 90 degree angle?

I cleaned it pretty good. What else should I do?

Ranger
04-11-07, 01:03 AM
It's probably open a Crack to keep it idling. With the engine off, it should close down and seal completely. Without a FSM to run a diagnosis on the TPS, you could throw one at it and hope that it cures the problem.

The Director
04-13-07, 02:54 AM
Now..........changed the TPS. P085 is still on. Service Engine Soon is still on.

Although, I've been noticing that the throttle blade taps for several seconds after I turn off the engine. Also, the motor (or wahtever it is) on the opposite side of the TPS on the Throttle body keeps jittering while the throttle blade taps. (It pulls on a wire that make the engine rev.)


Is this in realation to the P085 code?

What next?!?!?!?!?! Help!!!! I need to pass the Smog check!!

Ranger
04-13-07, 11:35 AM
I've been noticing that the throttle blade taps for several seconds after I turn off the engine. Also, the motor (or wahtever it is) on the opposite side of the TPS on the Throttle body keeps jittering while the throttle blade taps.
That is a sign of a failing ISC (Idle Speed Control) motor. Do a search for it. It has been discussed many times. Might be able to clean the contacts. If that doesn't help it will need replacement.

The Director
04-15-07, 04:28 PM
Update.....I finally fixed it. Cleared all codes including the Service Engine Soon light.

All I did was replace the TPS, cleaned the throttle body, cleaned the ISC motor contacts and performed the idle learn procedures.

Thanks for everyones help. Much appreciated.