: Intermittent '93 STS problem



sts93gt
03-17-07, 07:13 PM
I've had my '93 STS for abt a year now, and love it. Until abt 3 weeks ago, the only issue I have had involved tires. I am going to list my problems and symptoms chronologically; hopefully, someone can point me in the right direction.
3 weeks ago:
SES light came on intermittently. Pulled codes and got P041(Cam sensor)
Came and went for abt a week, no other issues.
2 weeks ago:
Driving home from work, SES light came on,more or less as usual. Stopped for gas,and when I was done, the car would not start. Power everywhere,starter turned,just no fire. Pulled codes,got P041(H),P083(C).After abt 20 minutes the car started, and all was well. Since then, if the car is shut off when the SES light is on, the 20 minutes are required before it will start. Also, the idle speed has started to fluctuate, to the point that the car has stalled a couple of times.Also, my analog tach has stopped functioning.
Last week:
Started the car coming home from work.After abt 10 minutes of city driving, I got on an onramp to the highway and immediately after I got on the highway, the engine just quit. No backfire,just quit. Coasted to the side of the road and waited 40 minutes before it would start. More codes:
P023 Electronic Spark Timing (EST) Signal problem
P041 No Cam Reference Signal from Ignition Control Module
P053 Distributor Signal Interrupt
P081 24X Signal problem
P095 Stall detected
Yesterday:
Left work again....see above. Car died in EXACTLY the same spot, with the same results. I might add, that the car is not driven all week. I am a trucker, and after parking on Monday, it is not moved until Friday.

Any Ideas?.....How can I diagnose this problem? Is it the ICM?....wiring.....CKM sensors...Cam sensor?
Any help is appreciated
Thanks,Glen

sts93gt
03-17-07, 07:16 PM
Re: Above
That code should be P083 24x signal problem

sts93gt
03-17-07, 07:51 PM
Just got some new codes:
P030 ISC RPM out of range
P035 PCM reference low signal voltage Out of Range