Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 4 of 4

Thread: XM Radio/Issue Question

  1. #1
    BobbyG 714 is offline Cadillac Owners Member
    Automobile(s): 2007 Escalade Ext
    Join Date
    Jan 2014
    Posts
    3

    XM Radio/Issue Question

    New to boards and first post. If I am not doing something wrong I would appreciate some guidance.

    I purchased a 2007 Escalade Ext about a month ago and transferred my XM subscription with no issues. The receiver has been working fine until last night. I am now getting the word "busy" when I try and tune to an XM station. Nothing comes up and the station ids ect. don't work either. It then show aux 1 aux 2 like it is trying to locate, Any help appreciated. Thank you.

    Bob


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    wesyder's Avatar
    wesyder is online now Cadillac Owners Connoisseur
    Automobile(s): 08 Escalade ESV awd, 05 Yukon Xl Denali awd, 06 SRX sold
    Join Date
    Mar 2009
    Location
    Eastvale Calif
    Posts
    1,812
    It sound like there may be an aftermarket ipod adapter installed possibly like an isimple unit with it showing aux1 and aux2, is there an ipod cable in the vehicle?

  4. #3
    BobbyG 714 is offline Cadillac Owners Member
    Automobile(s): 2007 Escalade Ext
    Join Date
    Jan 2014
    Posts
    3

    Re: XM Radio/Issue Question

    Funny you should say that. I just looked and there are some video cables and what looks to be an ipod cable in the glovebox. I have had not had any issues with my XM until yesterday and then it just says XM Aux 1 busy then says aux 2 and nothing. Hope that helps, so frustrating.

  5. #4
    wesyder's Avatar
    wesyder is online now Cadillac Owners Connoisseur
    Automobile(s): 08 Escalade ESV awd, 05 Yukon Xl Denali awd, 06 SRX sold
    Join Date
    Mar 2009
    Location
    Eastvale Calif
    Posts
    1,812
    Yeah your gonna have to find that adapter and remove or replace it, it ties into the system behind the radio... Pm me your email i want you to see this video to see if it helps, also is this a nav unit


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum