Cruise Control switch replacement
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 7 of 7
Cadillac Escalade, EXT and ESV Forum - 2007-2014 Discussion, Cruise Control switch replacement in Cadillac Escalade Forums; My 2010 ESV cruise control works 25% of the time. It always powers on but fails to set the speed. ...
  1. #1
    venom93corba is offline Cadillac Owners Member
    Join Date
    Oct 2013
    Posts
    2

    Cruise Control switch replacement

    My 2010 ESV cruise control works 25% of the time. It always powers on but fails to set the speed. I hoping it's just a switch but I'm trying to figure out how to get this sucker off. It looks like I might have to take the horn pad off. I don't see any screws. Anyone ever take one off?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    MrHolland's Avatar
    MrHolland is offline Super Moderator
    Automobile(s): 2010 Platinum Escalade, 1996 Fleetwood Brougham
    Join Date
    Jul 2010
    Location
    Midwest
    Age
    39
    Posts
    3,806

    Re: Cruise Control switch replacement

    I'm unsure how to remove the cruise control switch, I would begin with easier remedies such as a brake switch.

  4. #3
    SpyShops NY's Avatar
    SpyShops NY is offline Cadillac Owners Fanatic
    Automobile(s): 1999 Escalade, 2004 CTS, 2003 ESV, Now 2008 Escalade
    Join Date
    Oct 2012
    Location
    Fresh Meadows, NY
    Age
    35
    Posts
    424

    Re: Cruise Control switch replacement

    Its the switch that connects the brake pedal I paid 15$ off of amazon to replace

  5. #4
    wesyder's Avatar
    wesyder is offline Cadillac Owners Enthusiast
    Automobile(s): 08 Escalade ESV awd, 05 Yukon Xl Denali awd, 06 SRX sold
    Join Date
    Mar 2009
    Location
    Eastvale Calif
    Posts
    831
    Quote Originally Posted by venom93corba
    My 2010 ESV cruise control works 25% of the time. It always powers on but fails to set the speed. I hoping it's just a switch but I'm trying to figure out how to get this sucker off. It looks like I might have to take the horn pad off. I don't see any screws. Anyone ever take one off?
    i determined my faulty brake switch with the tec2

  6. #5
    Cadillac Cust Svc's Avatar
    Cadillac Cust Svc is offline Cadillac Customer Service
    Automobile(s): All Cadillac vehicles!
    Join Date
    Mar 2010
    Location
    Michigan
    Posts
    10,266

    Re: Cruise Control switch replacement

    Quote Originally Posted by venom93corba View Post
    My 2010 ESV cruise control works 25% of the time. It always powers on but fails to set the speed. I hoping it's just a switch but I'm trying to figure out how to get this sucker off. It looks like I might have to take the horn pad off. I don't see any screws. Anyone ever take one off?
    Hello venom93corba,

    Welcome to Cadillac Owners! We are happy to have you part of the community. I apologize you are experiencing an issue with your cruise control. I understand you are looking for advice from other forum members, but if you would like to further discuss your situation with us and work with a dealer, please let me know. I can be contacted via private message and I am here to assist.

    Sincerely,

    Laura M.
    Cadillac Customer Care

  7. #6
    venom93corba is offline Cadillac Owners Member
    Join Date
    Oct 2013
    Posts
    2
    I ended up unplugging the brake switch and plugging it back in and it's worked 100% of the time. Weird.

  8. #7
    wesyder's Avatar
    wesyder is offline Cadillac Owners Enthusiast
    Automobile(s): 08 Escalade ESV awd, 05 Yukon Xl Denali awd, 06 SRX sold
    Join Date
    Mar 2009
    Location
    Eastvale Calif
    Posts
    831
    Quote Originally Posted by venom93corba
    I ended up unplugging the brake switch and plugging it back in and it's worked 100% of the time. Weird.
    cool

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting