Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 4 of 4

Thread: Anybody have reviews or have tried these?

  1. #1
    kazza93203's Avatar
    kazza93203 is offline Cadillac Owners Fanatic
    Automobile(s): 07 Escalade
    Join Date
    Aug 2011
    Age
    30
    Posts
    190

    Anybody have reviews or have tried these?

    [IMG][/IMG]


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    Cadsrfun is offline Cadillac Owners Member
    Automobile(s): 2010 Silver Escalade ESV Platinum
    Join Date
    Jan 2012
    Location
    Templeton CA
    Posts
    61

    Re: Anybody have reviews or have tried these?

    I have no personal experience with them. A google search shows peeps have misfires with them after a while. There are some good reviews too but mostly from advertisements. If you do take a chance with them if you get any misfire issues don't forget to start with changing plugs back to stock.

  4. #3
    surburban99 Guest

    Re: Anybody have reviews or have tried these?

    I have one in my lawn mower

  5. #4
    kazza93203's Avatar
    kazza93203 is offline Cadillac Owners Fanatic
    Automobile(s): 07 Escalade
    Join Date
    Aug 2011
    Age
    30
    Posts
    190
    Lmao on a lawn mower huh lol

    Well I decided why not let's put em in. Actually runs pretty good. I'm not saying omg they add power! But the vibration/misfire at idle is gone so that's a plus. Took me about a hour with a lift. Oh and if anybody has over 80k miles be ready to buy some plug wires lol. 3 out of 8 broke.


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum