navigation jumping around
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 7 of 7
Cadillac Escalade, EXT and ESV Forum - 2007-2014 Discussion, navigation jumping around in Cadillac Escalade Forums; I recently did three things: 1) tinted the windows including the windshield banner, I cannot see for sure if it ...
  1. #1
    psuscott0483 is offline Cadillac Owners Member
    Automobile(s): 07 EXT
    Join Date
    May 2012
    Location
    Kutztown, PA
    Age
    31
    Posts
    39

    navigation jumping around

    I recently did three things: 1) tinted the windows including the windshield banner, I cannot see for sure if it goes in front of any sensors but it doesn't appear to 2) hung my ezpass right next to the mirror 3) installed a lockpick which is in line between the car and the factory nav for those who dont know. now, my navigation jumps all over the road and on/off of it I am constantly 50-100 yards ahead of where it says I am and it gets confused at every intersection. I've pulled the ezpass and it still acts up so either that wasn't the problem or the little transponder has scrambled the nav sensor?

    any thoughts? id rather not make yet another trip to the dealor & I have a feeling they will argue it is my lockpick id rather not rip it out to find the same problem still exist

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    kazza93203's Avatar
    kazza93203 is offline Cadillac Owners Fanatic
    Automobile(s): 07 Escalade
    Join Date
    Aug 2011
    Age
    27
    Posts
    190
    Lock pick for sure! I've had my lock pick for about 2 years now and just recently it starting doing the same. I dnt know why. Not sure if a update is avail for it.

  4. #3
    psuscott0483 is offline Cadillac Owners Member
    Automobile(s): 07 EXT
    Join Date
    May 2012
    Location
    Kutztown, PA
    Age
    31
    Posts
    39

    Re: navigation jumping around

    figures, I read that someone had called them asking about an update and the guy just laughed. I am running the version it says is most current on their website. I also read in the instructions to get it to work with early 07 models some dip switches needed to be adjusted perhaps I will try that.

  5. #4
    Rich08's Avatar
    Rich08 is offline Cadillac Owners Fanatic
    Automobile(s): 2008 Escalade EXT
    Join Date
    Feb 2013
    Location
    Jersey
    Posts
    136

    Re: navigation jumping around

    I have an isimple gateway in 08 and my nav sucks its way off. I've been told the isimple is the problem, the lockpick will probably be your problem too.

  6. #5
    chakde's Avatar
    chakde is offline Cadillac Owners Fanatic
    Automobile(s): 2011 Escalade EXT, 2012 Escalade ESV Platinum
    Join Date
    Mar 2011
    Location
    Fort McMurray, AB
    Posts
    147

    Re: navigation jumping around

    Lockpick gives me the same issue as well. As the above posters have mentioned this is to do with Lockpick install. I have a navTV in my other truck and have no issues with that.

  7. #6
    psuscott0483 is offline Cadillac Owners Member
    Automobile(s): 07 EXT
    Join Date
    May 2012
    Location
    Kutztown, PA
    Age
    31
    Posts
    39

    Re: navigation jumping around

    I wonder if it would be possible to unhook the part of lockpick that controls the nav. is it 1 of the 3 plugs that goes into the back of the factory unit? could it be left unplugged and just use the factory plug?

  8. #7
    48Dodge is offline Cadillac Owners Fanatic
    Automobile(s): '08 Escalade ESV
    Join Date
    Mar 2011
    Age
    38
    Posts
    435
    I had an issue with my lockpick a couple times. First time I disconnected the battery for 15 minutes. Second time I just disconnected the lockpick and reconnected. My gps was showing me about 1/2 block ahead the first time and 1/2 block back the 2nd time. Makes for a lot of missed turns in unknown areas. Everything has been fine for over a year though

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting