More Battery Issues
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 15 of 17
Cadillac Escalade, EXT and ESV Forum - 2007-2014 Discussion, More Battery Issues in Cadillac Escalade Forums; Damn these batteries! I walked out the door to leave for work this morning at 430 in the pouring rain. ...
  1. #1
    Banshee8732 is offline Cadillac Owners Fanatic
    Automobile(s): 2008 Escalade
    Join Date
    Mar 2013
    Location
    WI
    Age
    26
    Posts
    108

    More Battery Issues

    Damn these batteries! I walked out the door to leave for work this morning at 430 in the pouring rain. Hit the unlock button on the remote as I'm walking up to the beast..no noise from the door locks and no approach lighting..NOOOOO! I hit the remote about 6 more times, to no avail. Major extinction burst lol. I unlock it with the key and hit the ignition (as if it was going to do any good). Had it towed in, dealer is going to charge it in the morning and I'm taking it back for the weekend. Service is scheduled for Monday. I can hear it already: we can't find anything wrong.

    This is the 2nd time the battery has kicked the bucket overnight on me. According to Carfax it happened to the other owner also. Once the dealer gets done stumbling around in the dark with it I'll probably end up buying a replacement battery. I've got an iSimple Gateway and 2 10" subs. I'll carry around a booster pack before I remove my audio equipment. Anyone else out there with dead battery problems...you're not alone.

    ----------

    Hey just noticed this..http://www.optimabatteries.com/us/en/support/faqs/ the pic at the top. Maybe it's a sign lol

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    hrpatel17926 is offline Cadillac Owners Fanatic
    Automobile(s): 2007 CTS, 2007 ESV
    Join Date
    Sep 2012
    Location
    The city of the 500
    Age
    43
    Posts
    218
    Banshee

    Are your seat heaters\coolers working properly. I say this because in certain trucks these modules go bad and are sucking the power with the truck off. Have them check the modules under the pass seat. If you want to try unplug the harness and see what happens. I am on my second module.

  4. #3
    blackex is offline Cadillac Owners Fanatic
    Automobile(s): 2007 Cadillac Escalade Base
    Join Date
    Aug 2010
    Location
    Troy, Michigan
    Age
    29
    Posts
    379

    Re: More Battery Issues

    Possible your amp is constantly on? When your vehicle is off the amp should not have power. I would check your accessories first to see if they are draining your battery otherwise you may end up with another dead battery after they replace it.

  5. #4
    Banshee8732 is offline Cadillac Owners Fanatic
    Automobile(s): 2008 Escalade
    Join Date
    Mar 2013
    Location
    WI
    Age
    26
    Posts
    108

    Re: More Battery Issues

    Heated/cooled seats seem to be working fine. Will keep it in mind. What happened that made you know the module was bad?

    Amp is off when the truck is off. Locking/unlocking and opening/closing the doors causes the amp to turn on for about 30 seconds but then it shuts off for good. If I'm in the truck and open the door to turn off the radio, the amp shuts off like it should. Now once it's off if I lock it or open the door, it sends a signal to the amp for about 30 seconds. However it's not in my wiring because before I hooked everything up I checked the Bose amp to sub connection and it does that same thing with no aftermarket amp hooked up. I checked my 11 Silverado, same thing. Basically, locking and opening the door sends a signal through the stereo system. I don't know why.

    Anyway..the dealer just called. The battery tested bad and they're replacing it after lunch.

  6. #5
    MrHolland's Avatar
    MrHolland is online now Super Moderator
    Automobile(s): 2010 Platinum Escalade, 1996 Fleetwood Brougham
    Join Date
    Jul 2010
    Location
    Midwest
    Age
    39
    Posts
    3,997

    Re: More Battery Issues

    Delco batteries are junk, as many have reported. Most have cured all that ails them with a different brand of battery and or adding a second battery. There's a write up in the FAQs/Tech info sticky at the top of our section.

  7. #6
    Pillow is offline Cadillac Owners Fanatic
    Automobile(s): 2010 Escalade ESV & 2005 CTS-V
    Join Date
    May 2010
    Location
    Warrenton, VA
    Age
    40
    Posts
    111

    Re: More Battery Issues

    Take the time for a Big 3 upgrade when doing your battery if you are drawing hard on a sound system. Really helps on the neg side of the current.

  8. #7
    Banshee8732 is offline Cadillac Owners Fanatic
    Automobile(s): 2008 Escalade
    Join Date
    Mar 2013
    Location
    WI
    Age
    26
    Posts
    108

    Re: More Battery Issues

    I'm definitely going to get an upgraded battery. This dead overnight problem is all too common with Delco batteries from what I've read on here so far. I'm not sure if I want to tackle adding a 2nd battery.

    What's a big 3 upgrade?

  9. #8
    MrHolland's Avatar
    MrHolland is online now Super Moderator
    Automobile(s): 2010 Platinum Escalade, 1996 Fleetwood Brougham
    Join Date
    Jul 2010
    Location
    Midwest
    Age
    39
    Posts
    3,997

    Re: More Battery Issues

    Updating the ground. Google it, many write ups and tutorials!!

  10. #9
    kazza93203's Avatar
    kazza93203 is offline Cadillac Owners Fanatic
    Automobile(s): 07 Escalade
    Join Date
    Aug 2011
    Age
    27
    Posts
    190
    Best to do a battery draw test. That will rule out anything that is creating a draw(draining your battery). 2nd battery is always a good option too.

  11. #10
    K9Caddy is offline Cadillac Owners Enthusiast
    Automobile(s): 2009 AWD Escalade Ultra Luxury Raven Black
    Join Date
    Oct 2009
    Age
    36
    Posts
    885

    Re: More Battery Issues

    I had a battery drain issue, even with a dual yellow Optima setup. I narrowed the issue down to the that stupid Lock-Pick contraption. Once I removed that POS, problem solved.

  12. #11
    zam2000 is offline Cadillac Owners Member
    Automobile(s): Escalade ESV, GL, S class
    Join Date
    Aug 2009
    Posts
    58

    Re: More Battery Issues

    Happened with me 3 times. The first time was right after I picked up the car from the dealer lot. Went home that night, try to program the garage and the phone, listen to the radio, less than 30 all together. Next day, the car wouldn't start.

    Even with warranty replacement (and Cadillac send road-home assistant services to my house every time, very prompt & professional services), on the third time, I was tired of it. On the third time, I bought the Optima battery and the guy put it on for me, some adaptor needed.

    Haven't have battery problem for the last 2 years. Before that, every six months.


    Quote Originally Posted by Banshee8732 View Post
    Damn these batteries! I walked out the door to leave for work this morning at 430 in the pouring rain. Hit the unlock button on the remote as I'm walking up to the beast..no noise from the door locks and no approach lighting..NOOOOO! I hit the remote about 6 more times, to no avail. Major extinction burst lol. I unlock it with the key and hit the ignition (as if it was going to do any good). Had it towed in, dealer is going to charge it in the morning and I'm taking it back for the weekend. Service is scheduled for Monday. I can hear it already: we can't find anything wrong.

    This is the 2nd time the battery has kicked the bucket overnight on me. According to Carfax it happened to the other owner also. Once the dealer gets done stumbling around in the dark with it I'll probably end up buying a replacement battery. I've got an iSimple Gateway and 2 10" subs. I'll carry around a booster pack before I remove my audio equipment. Anyone else out there with dead battery problems...you're not alone.

    ----------

    Hey just noticed this..http://www.optimabatteries.com/us/en/support/faqs/ the pic at the top. Maybe it's a sign lol

  13. #12
    Banshee8732 is offline Cadillac Owners Fanatic
    Automobile(s): 2008 Escalade
    Join Date
    Mar 2013
    Location
    WI
    Age
    26
    Posts
    108

    Re: More Battery Issues

    It happened again. There's no question now I'm going with 2 batteries. I'm sick of it. This battery is about 3 weeks old.

    How exactly does having 2 batteries help us? Does it just extend the time before the batteries run completely dead? Or if the 2nd battery is only connected to the starter, and not the rest of the electrical system, does that keep it isolated from anything that could drain it?

    ----------

    I'm checking gmpartsdirect.com for the cables. I see positive and negative cables for both main and aux batteries. I'm figuring I need 1 of each for the aux battery?

  14. #13
    gdirty5 is offline Cadillac Owners Member
    Automobile(s): cts
    Join Date
    Oct 2009
    Posts
    86

    Re: More Battery Issues

    If a brand new battery is draining in 3 weeks either your alternator isnt charging it or you have a short in the system or some sort of draw....

  15. #14
    Banshee8732 is offline Cadillac Owners Fanatic
    Automobile(s): 2008 Escalade
    Join Date
    Mar 2013
    Location
    WI
    Age
    26
    Posts
    108

    Re: More Battery Issues

    It's at the dealer again. We'll see what they say this time. Hopefully this gets sorted out right quick.

  16. #15
    Banshee8732 is offline Cadillac Owners Fanatic
    Automobile(s): 2008 Escalade
    Join Date
    Mar 2013
    Location
    WI
    Age
    26
    Posts
    108

    Re: More Battery Issues

    Got it back. Battery and alternator good. Checked parasitic drain, 22-31ma, within spec. Programmed BCM and rear heated seat module. Disconnected all aftermarket accessories (isimple gateway, Vizualogic a1150 headrest DVD players, power inverter. All installed before I purchased it). Also: repaired radio wires that were cut during installation of accessories. Wonder what that was about. I assume it was done during the Gateway install, only thing behind the radio as far as I can tell.

    Something else interesting-- according to Carfax. 1st owner had it approx 3 years, 22k miles. No record of battery issues. 2nd owner had it a year, 7k miles. 2 batteries replaced, negative cable replaced. Makes you wonder.. 2nd owner installs all this aftermarket stuff and problems start? I hope so- easy fix. Time will tell now.

    ----------

    But...if it was something aftermarket, why did my last battery test bad (bad cell)? Coincidence? Maybe repeated deep discharge caused it? Anyone have any thoughts on all of this?

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting