Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

Results 1 to 5 of 5

Thread: This is driving me insane enough to actually come back here and post...

  1. #1
    Playdrv4me's Avatar
    Playdrv4me is offline Cadillac Owners 10000+ Posts
    Automobile(s): 1992 STS / 2005 MB G500 / 2003 STS / 2006 XLR-V
    Join Date
    Nov 2003
    Location
    TPA / STL / ICT / SAT
    Posts
    11,694

    This is driving me insane enough to actually come back here and post...

    Does anyone know how the 2008 Escalade supernav decides what the heck to use as the startup channel on the radio? It seems like ever since the battery died once (and it may have been happening even before then, I just can't remember), the radio just arbitrarily sets the startup station, usually from one of the presets. Currently I listen to a lot of SXM Public Radio, Road Dog Trucking and a few others. Right now, even if I shut it off on AM/FM radio or Road Dog or one of my other presets, it has decided that it wants to go BACK to SXM Public radio every single time you start it. Then arbitrarily three weeks from now it might start using RoadDog again or one of the other channels if I listen to one of those. Then every single time for WEEKS it will start up with that station. It always starts with a selected station, then it runs with that station for weeks at a time until it "catches" on another station listened to and starts using that one. It's as if whatever the mechanism is that tells it what station you shut it off at is simply being ignored.

    This has gone from a minor annoyance to a full blown war as I figure out why it's doing this. Any ideas before I pull the negative battery cable and attempt a hard reset? Surely this isn't a "feature".

    The only external mitigating factor is that I have an iPod connection kit that passes through the XM input. It's been so long since I put it in I don't even remember which brand it is... PA something GM probably. But this didn't happen on the '07 I had a similar unit in. Also, it can just as easily decide it wants to make a startup station out of the regular radio as well.


  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    48Dodge is offline Cadillac Owners Fanatic
    Automobile(s): '08 Escalade ESV
    Join Date
    Mar 2011
    Age
    41
    Posts
    442

    Re: This is driving me insane enough to actually come back here and post...

    Occasionally I'll be listening to XM, take or make a phone call and when I end the call it will go back to whatever station I was listening to on FM. Doesn't happen every single time, but enough to notice that it's definitely a glitch.

  4. #3
    Join Date
    May 2004
    Posts
    247

    Re: This is driving me insane enough to actually come back here and post...

    Do you have an iPod adapter that plugs into your XM receiver installed? I had a PA20-GM in my 09 & every time my son borrowed the car & changed the channel, after I got it back it would revert to what he had it on every time I started the car, even though I had changed it back to my channel before I shut it off. Removing the PA20-GM solved the problem.

  5. #4
    Playdrv4me's Avatar
    Playdrv4me is offline Cadillac Owners 10000+ Posts
    Automobile(s): 1992 STS / 2005 MB G500 / 2003 STS / 2006 XLR-V
    Join Date
    Nov 2003
    Location
    TPA / STL / ICT / SAT
    Posts
    11,694

    Re: This is driving me insane enough to actually come back here and post...

    Quote Originally Posted by CadX6 View Post
    Do you have an iPod adapter that plugs into your XM receiver installed? I had a PA20-GM in my 09 & every time my son borrowed the car & changed the channel, after I got it back it would revert to what he had it on every time I started the car, even though I had changed it back to my channel before I shut it off. Removing the PA20-GM solved the problem.
    Yeah I either have that one or whatever the other brand is, but I brought that over from my '07 Lade and I don't remember it doing that. That has to be it then. I don't want to take that out so I guess I'll just live with it.

  6. #5
    Join Date
    May 2004
    Posts
    247

    Re: This is driving me insane enough to actually come back here and post...

    If you have the one that plugs into your XM receiver behind the glove box, it would be real simple to just unplug it, plug the cable from the head unit back into the XM & see if that fixes the problem - no tools required - don't even have to remove the iPod adapter.
    Now, if you have the one that mounts behind the head unit - that's another story........


Bookmarks

Cadillac Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Read about Lincoln | Buick | Kia Forte Forum