2009 Escalade is possessed with electrical demons! - Page 2
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 16 to 30 of 41
Like Tree4Likes
Cadillac Escalade, EXT and ESV Forum - 2007-2014 Discussion, 2009 Escalade is possessed with electrical demons! in Cadillac Escalade Forums; Thats awesome news. There may be some people that would argue this point, but GM is a great organization with ...
  1. #16
    MrHolland's Avatar
    MrHolland is offline Super Moderator
    Automobile(s): 2010 Platinum Escalade, 1996 Fleetwood Brougham
    Join Date
    Jul 2010
    Location
    Midwest
    Age
    40
    Posts
    4,336

    Re: 2009 Escalade is possessed with electrical demons!

    Thats awesome news. There may be some people that would argue this point, but GM is a great organization with a great product. One simply needs to find the proper dealership that fits them and responds to their problems. Enjoy your new car!!

  2. #17
    lee88's Avatar
    lee88 is offline Cadillac Owners Fanatic
    Join Date
    Mar 2012
    Posts
    146
    Quote Originally Posted by mrholland
    Thats awesome news. There may be some people that would argue this point, but GM is a great organization with a great product. One simply needs to find the proper dealership that fits them and responds to their problems. Enjoy your new car!!
    For once Mr holland and I agree!

  3. #18
    MrHolland's Avatar
    MrHolland is offline Super Moderator
    Automobile(s): 2010 Platinum Escalade, 1996 Fleetwood Brougham
    Join Date
    Jul 2010
    Location
    Midwest
    Age
    40
    Posts
    4,336

    Re: 2009 Escalade is possessed with electrical demons!

    Thank you sir!!

  4. #19
    harristw is offline Cadillac Owners Member
    Join Date
    Sep 2012
    Posts
    4

    Re: 2009 Escalade is possessed with electrical demons!

    You didn't have a stealth grey esv did you? I bought one a couple months ago and have the same problem. Also, since this issue affects the drivetrain would it be covered in the powertrain warranty?

  5. #20
    Cadillac Cust Svc's Avatar
    Cadillac Cust Svc is online now Cadillac Customer Service
    Automobile(s): All Cadillac vehicles!
    Join Date
    Mar 2010
    Location
    Michigan
    Posts
    11,788

    Re: 2009 Escalade is possessed with electrical demons!

    Harristw, I'm sorry to hear you're experiencing these concerns as well! I recommend having your dealer's specialized technicians view the concerns firsthand initially, so they can then determine coverage. And I'm happy to look into the matter for you, if you don't mind providing the last eight of your VIN. Please email me that information at Katie_Lucille@gmexpert.com for further assistance!

    Best,

    Katie
    Cadillac Customer Service

  6. #21
    CUTiger78's Avatar
    CUTiger78 is offline Cadillac Owners Member
    Automobile(s): 2011 ESV Premium
    Join Date
    Jul 2006
    Location
    NoVA
    Posts
    87

    Re: 2009 Escalade is possessed with electrical demons!

    Quote Originally Posted by hcvone View Post
    ... GM replaced my second 2007 Escalade that exploded in my garage....
    EXPLODED in your garage??? Haven't read about that one. Did a search and didn't find an old post about it. What's the story? Sounds like a good one!!

  7. #22
    cropdude is offline Cadillac Owners Member
    Automobile(s): 2009 Escalade
    Join Date
    Dec 2012
    Posts
    1

    Re: 2009 Escalade is possessed with electrical demons!

    Our Escalade started having these issues a few days ago, has anybody found a fix to this issue yet???0

  8. #23
    stogeman's Avatar
    stogeman is offline Cadillac Owners Member
    Automobile(s): 2008 Cadillac Escalade ESV Platinum
    Join Date
    Dec 2012
    Location
    NJ
    Age
    29
    Posts
    82
    Quick get a tech and some holy oil synthetic

  9. #24
    Wood 13 is offline Cadillac Owners Member
    Automobile(s): None
    Join Date
    Dec 2012
    Posts
    5

    Re: 2009 Escalade is possessed with electrical demons!

    Quote Originally Posted by harristw View Post
    You didn't have a stealth grey esv did you? I bought one a couple months ago and have the same problem. Also, since this issue affects the drivetrain would it be covered in the powertrain warranty?
    I'm curious to know as well the color and location of this trade-in. Especially, since I am going to pick-up a 09 platinum esv this weekend. LakeGuy - do you mind sharing this information whether on the site or via a PM to me please? Thanks.

  10. #25
    texas1's Avatar
    texas1 is offline Cadillac Owners Fanatic
    Join Date
    Aug 2012
    Location
    DFW
    Posts
    146

    Re: 2009 Escalade is possessed with electrical demons!

    i all so had this problem took it to the dealer nothing changed the battery nothing i kept looking in the interwebs and found a guy that had the same problem any way long story. Cut the + and negative terminals of the factory cabels and install new terminals and it will solve your problem you welcome
    David2008ESV and David2008ESV like this.

  11. #26
    David2008ESV is offline Cadillac Owners Member
    Automobile(s): 2008 Escalade ESV
    Join Date
    May 2013
    Posts
    9

    Re: 2009 Escalade is possessed with electrical demons!

    We just bought a 2008 Escalade ESV on the 27th of April with just about 60,000 miles.

    We've been driving it without issue, since we purchased the vehicle. Absolutely no signs of anything being suspect.

    Last night, my wife, two year old son and I left the restaurant where we had dinner and the problems began.

    I hit the remote to open the rear gate so I could place the to go box from the restaurant, closed it by hitting the button. All good so far. Then I unlocked the doors with my remote. I got in the Escalade, interior lights came on and then I placed the key in the ignition, turned it to the first position, all dash lights came on, turn to start and everything went BLACK - interior lights went OUT, no clicking from the ignition - nothing.

    It was like it had a dead battery.

    I tried to jump it, got the interior lights on - so I thought we were good to go, tried to start and the same thing - everything went BLACK - no lights whatsoever.

    Now I can't even get it to do a darn thing. Finally had to have it towed home and now it sits in my driveway.

    I've read a lot of posts here and other sites, it sure seems there are a lot of TSBs on this model year regarding electrical.

    Did I just buy a lemon? That's sure how I feel right about now...we've only put maybe 500 miles on this thing so far and it is now just a cold piece of steel decoration in my driveway.

    Any help would be GREATLY appreciated.

    David

  12. #27
    Cadillac Cust Svc's Avatar
    Cadillac Cust Svc is online now Cadillac Customer Service
    Automobile(s): All Cadillac vehicles!
    Join Date
    Mar 2010
    Location
    Michigan
    Posts
    11,788

    Re: 2009 Escalade is possessed with electrical demons!

    Quote Originally Posted by David2008ESV View Post
    We just bought a 2008 Escalade ESV on the 27th of April with just about 60,000 miles.

    We've been driving it without issue, since we purchased the vehicle. Absolutely no signs of anything being suspect.

    Last night, my wife, two year old son and I left the restaurant where we had dinner and the problems began.

    I hit the remote to open the rear gate so I could place the to go box from the restaurant, closed it by hitting the button. All good so far. Then I unlocked the doors with my remote. I got in the Escalade, interior lights came on and then I placed the key in the ignition, turned it to the first position, all dash lights came on, turn to start and everything went BLACK - interior lights went OUT, no clicking from the ignition - nothing.

    It was like it had a dead battery.

    I tried to jump it, got the interior lights on - so I thought we were good to go, tried to start and the same thing - everything went BLACK - no lights whatsoever.

    Now I can't even get it to do a darn thing. Finally had to have it towed home and now it sits in my driveway.

    I've read a lot of posts here and other sites, it sure seems there are a lot of TSBs on this model year regarding electrical.

    Did I just buy a lemon? That's sure how I feel right about now...we've only put maybe 500 miles on this thing so far and it is now just a cold piece of steel decoration in my driveway.

    Any help would be GREATLY appreciated.

    David
    Hello David,

    I am sorry your experiencing these issues. I understand how frustrating it can be when something goes wrong with your vehicle, especially after recently buying it. If you private message me your contact information, VIN and current mileage, I am more than happy to further discuss these concerns with you and explore our options.

    Sincerely,

    Laura M.
    Cadillac Customer Service

  13. #28
    Banshee8732 is offline Cadillac Owners Fanatic
    Automobile(s): 2008 Escalade
    Join Date
    Mar 2013
    Location
    WI
    Age
    26
    Posts
    110

    Re: 2009 Escalade is possessed with electrical demons!

    Quote Originally Posted by David2008ESV View Post
    We just bought a 2008 Escalade ESV on the 27th of April with just about 60,000 miles.

    We've been driving it without issue, since we purchased the vehicle. Absolutely no signs of anything being suspect.

    Last night, my wife, two year old son and I left the restaurant where we had dinner and the problems began.

    I hit the remote to open the rear gate so I could place the to go box from the restaurant, closed it by hitting the button. All good so far. Then I unlocked the doors with my remote. I got in the Escalade, interior lights came on and then I placed the key in the ignition, turned it to the first position, all dash lights came on, turn to start and everything went BLACK - interior lights went OUT, no clicking from the ignition - nothing.

    It was like it had a dead battery.

    I tried to jump it, got the interior lights on - so I thought we were good to go, tried to start and the same thing - everything went BLACK - no lights whatsoever.

    Now I can't even get it to do a darn thing. Finally had to have it towed home and now it sits in my driveway.

    I've read a lot of posts here and other sites, it sure seems there are a lot of TSBs on this model year regarding electrical.

    Did I just buy a lemon? That's sure how I feel right about now...we've only put maybe 500 miles on this thing so far and it is now just a cold piece of steel decoration in my driveway.

    Any help would be GREATLY appreciated.

    David
    I heard that. The 3rd day I had mine it was dead in my driveway. RKE worked and the steps came down but when I tried to start it I got 1 click and that was all. The dealer couldn't find anything wrong. Do you still have the Delco battery? I've seen a fair share of posts here with members replacing the Delco battery and being good to go from there.

  14. #29
    Cadsrfun is offline Cadillac Owners Member
    Automobile(s): 2010 Silver Escalade ESV Platinum
    Join Date
    Jan 2012
    Location
    Templeton CA
    Posts
    64

    Re: 2009 Escalade is possessed with electrical demons!

    David, sounds like corroded battery connections to me. Remove and clean well. the problem may be evident as you clean. Also check the ground to the head and the positive at the starter if you don't find a problem at the battery connections. Good luck.
    2kflhr and 2kflhr like this.

  15. #30
    David2008ESV is offline Cadillac Owners Member
    Automobile(s): 2008 Escalade ESV
    Join Date
    May 2013
    Posts
    9

    Re: 2009 Escalade is possessed with electrical demons!

    Thanks.

    I thought it was corrosion too...the battery (according to carfax) was replaced in 2013 with the original equipment battery (AC Delco) and it looks very clean. I did remove the connections from the posts and while I didn't see any corrosion, I did see a little discolor - so I cleaned both sides and posts very well, replaced and still nothing.

    I haven't looked at the grounding as closely as I would like, but it did look like it was okay as well as the starter.

    Oddly, yesterday I went out to the ESV to give it one last check and out of curiosity I used the keyless remote to unlock the doors - just to see if it would work and to my surprise it unlocked the doors, and the interior lights came on when I opened the door.

    So I sat in the truck, closed the door and tried to start it. Turning the key to the first position and all the lights on the dash came on, turn to start and it all went dead again. nothing.

    weird. and frustrating.

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting