Intro and yet another air ride question....not working but NO "Service Ride Control"
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 13 of 13
Cadillac Escalade, EXT and ESV Forum - 1999 - 2006 Discussion, Intro and yet another air ride question....not working but NO "Service Ride Control" in Cadillac Escalade Forums; All - Just bought an 06 Pearl Escalade a couple weeks back with 113k on the clock. It needs some ...
  1. #1
    Golfhack5 is offline Cadillac Owners Member
    Automobile(s): 2006 Escalade
    Join Date
    May 2014
    Age
    34
    Posts
    6

    Intro and yet another air ride question....not working but NO "Service Ride Control"

    All -

    Just bought an 06 Pearl Escalade a couple weeks back with 113k on the clock. It needs some TLC cosmetically but is very mechanically solid. I got a great deal on it (in my mind) so I'm very excited and will be using it as my daily and to tow our 19' boat. I'm sure I will have many questions (coming from an 11 G37xS) and have already gotten a ton of knowledge from threads here.

    My first question...my air ride is not working (surprise surprise) but there is no Service Ride Control message and that has me stumped. I checked the fuses as recommended and all were ok minus the Stud 1 40a fuse was blown. Replaced that but still nothing. I jumped the alcr relay (30 to 87) and nothing from the compressor but the jumper wire was SMOKING almost instantly. Is it a safe assumption that a bad compressor would cause this?

    I did a visual inspection of the rear shocks and the bladders are not obviously blown out (I have been unable to check for slow leaks because I cannot get the compressor going).

    I have a sneaky suspicion I will be replacing compressor and shocks but just want to make sure I understand the smoking jumper wire? Also anything else I can troubleshoot prior to shelling out money??

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,231
    Pull the relay until you can replace the compressor as likely its locked up
    That's why the jumper wire smoked

  4. #3
    Golfhack5 is offline Cadillac Owners Member
    Automobile(s): 2006 Escalade
    Join Date
    May 2014
    Age
    34
    Posts
    6

    Re: Intro and yet another air ride question....not working but NO "Service Ride Contr

    Thanks and will do...any reason you know of why the service ride control message is not showing??

  5. #4
    Retrax is offline Cadillac Owners Fanatic
    Automobile(s): 2003 Escalade EXT
    Join Date
    Jul 2013
    Location
    Saint Paul, MN
    Posts
    200

    Re: Intro and yet another air ride question....not working but NO "Service Ride Contr

    Mine never showed any errors. My compressor was destroyed and had a giant hole rusted through it. Both rear air shocks had dry rotted rubber bladders that would not come close to holding air. I never received any error messages. I replaced the compressor and watched it try to fill the rotten shocks. I let it run for about ten seconds and disconnected the battery. I replaced the shocks and everything pumped up and leveled out. It has worked fine since.

  6. #5
    Golfhack5 is offline Cadillac Owners Member
    Automobile(s): 2006 Escalade
    Join Date
    May 2014
    Age
    34
    Posts
    6

    Re: Intro and yet another air ride question....not working but NO "Service Ride Contr

    Thanks Retrax...my shocks are not visibly destroyed so I'll start with the air compressor and go from there.

  7. #6
    Retrax is offline Cadillac Owners Fanatic
    Automobile(s): 2003 Escalade EXT
    Join Date
    Jul 2013
    Location
    Saint Paul, MN
    Posts
    200

    Re: Intro and yet another air ride question....not working but NO "Service Ride Contr

    Maybe all you need is the compressor. If you get the dorman unit it comes with everything including the mounting nuts. Just take out the old one and put in the new. You will be able to hear it turn on and watch the rubber bladders on your rear shocks start to fill. If it looks good from there (I could hear and see multiple areas of leaky dry rotted rubber) and you don't think you have any leaks, spray down the rubber bladders with soapy water and look for bubbles indicating an air leak.

    With my new compressor and shocks my compressor will rarely run for a few seconds to top off the psi. With over 100,000 miles on the vehicle I would consider replacing all 4 shock absorbers anyway but that part is up to you.

  8. #7
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,231
    Quote Originally Posted by Golfhack5
    Thanks and will do...any reason you know of why the service ride control message is not showing??
    If it was from a dealer they will get the codes cleared so they don't have to mess with working on it(plus it makes it easier to sell(happened to be on the receiving end of that before with my mom's 02)

  9. #8
    Retrax is offline Cadillac Owners Fanatic
    Automobile(s): 2003 Escalade EXT
    Join Date
    Jul 2013
    Location
    Saint Paul, MN
    Posts
    200

    Re: Intro and yet another air ride question....not working but NO "Service Ride Contr

    I am thinking the same thing happened to me. The doctor who owned mine before me traded it in on a new ext. I wonder if the dealer gave him the estimate for 4 new shocks and compressor and talked him into buying new.

    Kind of hard to "miss" this on the 150 point "Gold Crest" inspection, or whatever they called it.

  10. #9
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,231
    Quote Originally Posted by Retrax
    I am thinking the same thing happened to me. The doctor who owned mine before me traded it in on a new ext. I wonder if the dealer gave him the estimate for 4 new shocks and compressor and talked him into buying new. Kind of hard to "miss" this on the 150 point "Gold Crest" inspection, or whatever they called it.
    Another point that dealers sales guys can't be trusted
    Man that hole is crazy hard to miss(that is if they really inspected it)

  11. #10
    BIG-KO is offline Cadillac Owners Member
    Automobile(s): 2003 escalade
    Join Date
    Mar 2014
    Location
    CHAMBERSBURG,PA
    Age
    47
    Posts
    17

    Re: Intro and yet another air ride question....not working but NO "Service Ride Contr

    Another route to think about is Airlift 1000 air bags for inside the rear coil springs. I had just purchased my lo mileage 03 ESV this year and both rear shocks bladders are blown and compressor is very noisy. The airlift bags were $80 compared to like $6-700 for factory shocks and compressor depending where and what brand you buy. Knowing I will have the tongue weight of my camper,5-people, two small dogs, firewood, and a cooler on board I wasn't real confident the tiny airbladders on the factory shocks were up to the tasks I was about to put them through. I just installed the bags this week and will find out just how well they work this coming weekend.

  12. #11
    Golfhack5 is offline Cadillac Owners Member
    Automobile(s): 2006 Escalade
    Join Date
    May 2014
    Age
    34
    Posts
    6

    Re: Intro and yet another air ride question....not working but NO "Service Ride Contr

    Thanks all! I found a new Arnott compressor on eBay yesterday that someone bought but didn't use. Got a great deal on it and I will report back once it's installed.

  13. #12
    Golfhack5 is offline Cadillac Owners Member
    Automobile(s): 2006 Escalade
    Join Date
    May 2014
    Age
    34
    Posts
    6

    Re: Intro and yet another air ride question....not working but NO "Service Ride Contr

    Just an update...I finally had a chance to crawl under the truck in some decent light and the shock bladders are toast. They aren't completely blown out but there are a couple visible holes and lots of dry rot. At least I know now why the compressor took a crap! The compressor arrived last week and I ordered new shocks yesterday that will be here tomorrow. Plan is to replace everything tomorrow night/Friday morning and I will post back once complete.

    For shocks I ended up going with Monroe's kit #90012. It converts all 4 corners to passive shocks but retains the auto leveling feature which is all I really care about since I do a fair amount of hauling our boat around. The kit includes all 4 shocks, air lines, and resistors to trick the computer....cost a whopping $132 shipped. I had a couple buddies who installed this same kit on their Yukon Denali's and they really like it. There's quite a few left on Amazon if anyone is looking for a little friendlier alternative from a cost perspective!

  14. #13
    Golfhack5 is offline Cadillac Owners Member
    Automobile(s): 2006 Escalade
    Join Date
    May 2014
    Age
    34
    Posts
    6

    **FIXED** another air ride question....not working but NO "Service Ride Control

    Just an update on this as I finally got around to replacing compressor and shocks last night. I installed the Arnott compressor and rebuilt the air drier. Went with Monroe shocks that retain the air leveling but eliminate active dampening. Everything installed surprisingly smooth and all works as it should. It was late by the time I got done so I didn't have a chance to solder in the resistors so that the Service Ride Control light doesn't come on but will be doing that soon.

    At the end of the day I had $270 into it and about 3 hours of my time. Now onto some annoying leaks (probably rear main) and the "clampless" CV boot I discovered last night during front shock install...grrr!

    So much for the 100+ point pre-purchase inspection by the dealer..............

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting