Brakes suddenly pull to the left!
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 3 of 3
Cadillac Escalade, EXT and ESV Forum - 1999 - 2006 Discussion, Brakes suddenly pull to the left! in Cadillac Escalade Forums; On my '05 Escalade, when you're braking, the wheel will suddenly jerk to the left for a half a second, ...
  1. #1
    caddydaddy's Avatar
    caddydaddy is offline Cadillac Owners Connoisseur
    Automobile(s): 2005 Escalade 6.0L 2WD, 2007 Jeep Grand Cherokee Limited CRD
    Join Date
    Jan 2003
    Location
    Belle Chasse, LA
    Age
    32
    Posts
    3,666

    Brakes suddenly pull to the left!

    On my '05 Escalade, when you're braking, the wheel will suddenly jerk to the left for a half a second, then it will stop pulling. After you come to a complete stop and release the brakes, the wheel will jerk immediately to the right, then stop! I've never had a vehicle to this, so I don't know what to think is the problem! Any ideas?

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,227
    Could be the wheel sensors

  4. #3
    caddydaddy's Avatar
    caddydaddy is offline Cadillac Owners Connoisseur
    Automobile(s): 2005 Escalade 6.0L 2WD, 2007 Jeep Grand Cherokee Limited CRD
    Join Date
    Jan 2003
    Location
    Belle Chasse, LA
    Age
    32
    Posts
    3,666

    Re: Brakes suddenly pull to the left!

    I finally was able to get my truck on a lift to see what was the cause of the pulling and noises I've been hearing;



    The drivers side A-arm bolt was VERY loose and the A-arm was sliding around in the mount. I had an alignment done in August, and obviously the shop doesn't know how to use a torque wrench, or any wrench! I tightened it up and took it back to the shop today and had them redo the alignment!
    I am obviously NOT happy, since my wife uses this truck most of the times to drive our kids around, so I wrote an email to the corporate regional rep about this issue!

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting