2003 ESV Idle issue
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 3 of 3
Cadillac Escalade, EXT and ESV Forum - 1999 - 2006 Discussion, 2003 ESV Idle issue in Cadillac Escalade Forums; Hey guys, new to here and I have a problem thats driving me INSANE. My 03 ESV has about 230 ...
  1. #1
    Ravendarat is offline Cadillac Owners Member
    Automobile(s): 2003 Escalade ESV
    Join Date
    Nov 2013
    Age
    32
    Posts
    1

    2003 ESV Idle issue

    Hey guys, new to here and I have a problem thats driving me INSANE. My 03 ESV has about 230 kms on it and I have a bad idle issue. Regardless of operating temp it will flutter idle between 100-700 ish rpm and stall out at times. The CEL light is on, I can't remember the exact code but it reported back as a MAF problem. I replaced the MAF and I still have the light and still have the idle problem. Do you guys have any ideas here? This truck has been nothing but a HUGE lemon since I owned it and this is just one more thing that is driving me nuts and I am really trying to figure this out so I can drive this truck without worrying. Thanks guys.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    MoistCabbage's Avatar
    MoistCabbage is online now Cadillac Owners 10000+ Posts
    Automobile(s): Crimson 2001 Seville STS, 1990 Seville (RIP)
    Join Date
    Sep 2010
    Location
    East Boston MA.
    Age
    26
    Posts
    21,533
    Assuming the new MAF isn't defective, the only other possibilities are a connector/wiring problem, or a faulty PCM.

  4. #3
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,559
    I hate to be obvious but did you clean the throttle body??

    Mine would idle like crap when I first got it and I had to clean the throttle body

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting