Nav radio wont come on
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 13 of 13
Cadillac Escalade, EXT and ESV Forum - 1999 - 2006 Discussion, Nav radio wont come on in Cadillac Escalade Forums; When I start my truck in the morning the temp is usually between 26-30 degrees and constantly getting colder well ...
  1. #1
    Txao1051's Avatar
    Txao1051 is offline Cadillac Owners Member
    Automobile(s): Escalade EXT
    Join Date
    Feb 2013
    Age
    26
    Posts
    98

    Nav radio wont come on

    When I start my truck in the morning the temp is usually between 26-30 degrees and constantly getting colder well no matter how long I warm the car up the nav radio won't come on until I have been driving the car for about 5 min. Is there something I can do to make sure it comes on right away again. Last winter I never had this problem even when it was as cold as -20.

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    the cadillac man's Avatar
    the cadillac man is online now Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,423
    Do you get any music or chimes from the speakers?

    Does the display do anything

    I would check the radio fuse in the under hood fuse box

  4. #3
    Txao1051's Avatar
    Txao1051 is offline Cadillac Owners Member
    Automobile(s): Escalade EXT
    Join Date
    Feb 2013
    Age
    26
    Posts
    98
    Quote Originally Posted by the cadillac man
    Do you get any music or chimes from the speakers? Does the display do anything I would check the radio fuse in the under hood fuse box
    Chimes come on but the lights In the unit don't even come on. The fuses are all good. It looks like the unit is dead. You know when you power te unit down the time is still displayed? Well it doesn't even do that!

  5. #4
    the cadillac man's Avatar
    the cadillac man is online now Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,423
    Quote Originally Posted by Txao1051
    Chimes come on but the lights In the unit don't even come on. The fuses are all good. It looks like the unit is dead. You know when you power te unit down the time is still displayed? Well it doesn't even do that!
    Try pulling the radio fuse for a bit and see if it resets the radio
    I had this happen to me except the lights stayed on no matter if the head lights were on or not pulling the radio fuse for a bit fixed it

  6. #5
    Txao1051's Avatar
    Txao1051 is offline Cadillac Owners Member
    Automobile(s): Escalade EXT
    Join Date
    Feb 2013
    Age
    26
    Posts
    98
    Quote Originally Posted by the cadillac man
    Try pulling the radio fuse for a bit and see if it resets the radio I had this happen to me except the lights stayed on no matter if the head lights were on or not pulling the radio fuse for a bit fixed it
    Tried that this morning to no avail. I took it out for about 5 min when the truck was on...

  7. #6
    the cadillac man's Avatar
    the cadillac man is online now Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,423
    Quote Originally Posted by Txao1051
    Tried that this morning to no avail. I took it out for about 5 min when the truck was on...
    Then its dead completely then

  8. #7
    Txao1051's Avatar
    Txao1051 is offline Cadillac Owners Member
    Automobile(s): Escalade EXT
    Join Date
    Feb 2013
    Age
    26
    Posts
    98
    Quote Originally Posted by the cadillac man
    Then its dead completely then
    It comes on after driving the truck for approximately 5 minutes

    ----------

    Usually the exact same spot on my drive.

  9. #8
    the cadillac man's Avatar
    the cadillac man is online now Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,423
    Quote Originally Posted by Txao1051
    It comes on after driving the truck for approximately 5 minutes ---------- Usually the exact same spot on my drive.
    That's odd

    Have you checked the wiring harness the plugs in the back of the radio to see if its loose

    It could be a wiring issue or ground somewhere if its working some time

  10. #9
    Txao1051's Avatar
    Txao1051 is offline Cadillac Owners Member
    Automobile(s): Escalade EXT
    Join Date
    Feb 2013
    Age
    26
    Posts
    98
    Quote Originally Posted by the cadillac man
    That's odd Have you checked the wiring harness the plugs in the back of the radio to see if its loose It could be a wiring issue or ground somewhere if its working some time
    Yea it's usually on mornings were temp is below 35 degrees

  11. #10
    Txao1051's Avatar
    Txao1051 is offline Cadillac Owners Member
    Automobile(s): Escalade EXT
    Join Date
    Feb 2013
    Age
    26
    Posts
    98
    So this morning I got in and started it up. The radio came on right away!!! Yay!!!! Spoke to soon As soon as I changed the channel it turned off. It came back on exactly 20 minutes later. Any ideas?

    Could it be the PAC OEM gm24 that I have to use as a converter for my amp?

  12. #11
    the cadillac man's Avatar
    the cadillac man is online now Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,423
    Quote Originally Posted by Txao1051
    So this morning I got in and started it up. The radio came on right away!!! Yay!!!! Spoke to soon As soon as I changed the channel it turned off. It came back on exactly 20 minutes later. Any ideas? Could it be the PAC OEM gm24 that I have to use as a converter for my amp?
    Not sure but it might be as both the radio and amp is worked off the class 2 data bus

  13. #12
    Txao1051's Avatar
    Txao1051 is offline Cadillac Owners Member
    Automobile(s): Escalade EXT
    Join Date
    Feb 2013
    Age
    26
    Posts
    98
    I removed that PAC converter and everything is working again. Hmmm guess I won't be recommending that product to anyone

  14. #13
    the cadillac man's Avatar
    the cadillac man is online now Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,423
    Quote Originally Posted by Txao1051
    I removed that PAC converter and everything is working again. Hmmm guess I won't be recommending that product to anyone
    It may be bad and needs replacing

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting