First post...and big problem...
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 9 of 9
Cadillac Escalade, EXT and ESV Forum - 1999 - 2006 Discussion, First post...and big problem... in Cadillac Escalade Forums; Hello everyone! I have a 2003 ext, this is my first post after lurking for quite a while. Im having ...
  1. #1
    kantgetnun is offline Cadillac Owners Member
    Automobile(s): 2003 escalade ext
    Join Date
    Sep 2013
    Age
    39
    Posts
    13

    First post...and big problem...

    Hello everyone! I have a 2003 ext, this is my first post after lurking for quite a while. Im having some issues, about a week ago I had a p0430 code pop, i cleared it to see if it would happen again...it did, so after reading a few things here I switched the rear o2's side to side and also threw a boroscope down the cats, they looked ok not perfect but not bad either. the rear o2 code never popped up again, since i bought the truck a few weeks ago i decided to do a tune up, plugs, wires, fuel filter, and sea-foamed the fuel tank. everything was fine for a couple days...then a p0302 code flashed but not lit solid, (i was driving a bit hard when this happened) so i cleared it and waited to see if it would happen again. it did but this time a p0300 popped, first flashing then solid. within about 10 miles of driving back home it started to run really rough. felt like it wasn't going to make it home. I changed plugs again and checked all the wires. pulled the fuel rails and cleaned the injectors( didn't have them professionally done just sprayed them down really well). cleaned maf, changed fuel pressure regulator. Im getting 50 psi of fuel pressure with the key on, 48 psi at idle and 58 psi under throttle with no load. it runs rough all across the board, idle, under throttle with no load and even worse with a load. also swapped coils, no change. bank 1 looks to be running super lean. Im at a bit of a loss. I even drained all the fuel and replaced it with fuel from a different gas station just to be safe.
    thanks in advance for any help/opinions

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    wesyder's Avatar
    wesyder is offline Cadillac Owners Connoisseur
    Automobile(s): 08 Escalade ESV awd, 05 Yukon Xl Denali awd, 06 SRX sold
    Join Date
    Mar 2009
    Location
    Eastvale Calif
    Posts
    1,081
    Quote Originally Posted by kantgetnun
    Hello everyone! I have a 2003 ext, this is my first post after lurking for quite a while. Im having some issues, about a week ago I had a p0430 code pop, i cleared it to see if it would happen again...it did, so after reading a few things here I switched the rear o2's side to side and also threw a boroscope down the cats, they looked ok not perfect but not bad either. the rear o2 code never popped up again, since i bought the truck a few weeks ago i decided to do a tune up, plugs, wires, fuel filter, and sea-foamed the fuel tank. everything was fine for a couple days...then a p0302 code flashed but not lit solid, (i was driving a bit hard when this happened) so i cleared it and waited to see if it would happen again. it did but this time a p0300 popped, first flashing then solid. within about 10 miles of driving back home it started to run really rough. felt like it wasn't going to make it home. I changed plugs again and checked all the wires. pulled the fuel rails and cleaned the injectors( didn't have them professionally done just sprayed them down really well). cleaned maf, changed fuel pressure regulator. Im getting 50 psi of fuel pressure with the key on, 48 psi at idle and 58 psi under throttle with no load. it runs rough all across the board, idle, under throttle with no load and even worse with a load. also swapped coils, no change. bank 1 looks to be running super lean. Im at a bit of a loss. I even drained all the fuel and replaced it with fuel from a different gas station just to be safe. thanks in advance for any help/opinions
    possibly a bad ignition coil by your description

  4. #3
    kantgetnun is offline Cadillac Owners Member
    Automobile(s): 2003 escalade ext
    Join Date
    Sep 2013
    Age
    39
    Posts
    13
    Thread Starter

    Re: First post...and big problem...

    I bought a new coil and switched it to each cylinder and no change

  5. #4
    wesyder's Avatar
    wesyder is offline Cadillac Owners Connoisseur
    Automobile(s): 08 Escalade ESV awd, 05 Yukon Xl Denali awd, 06 SRX sold
    Join Date
    Mar 2009
    Location
    Eastvale Calif
    Posts
    1,081
    Quote Originally Posted by kantgetnun
    I bought a new coil and switched it to each cylinder and no change
    oops didnt see that in you first post, which plugs did you use

  6. #5
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,871
    Quote Originally Posted by kantgetnun
    Hello everyone! I have a 2003 ext, this is my first post after lurking for quite a while. Im having some issues, about a week ago I had a p0430 code pop, i cleared it to see if it would happen again...it did, so after reading a few things here I switched the rear o2's side to side and also threw a boroscope down the cats, they looked ok not perfect but not bad either. the rear o2 code never popped up again, since i bought the truck a few weeks ago i decided to do a tune up, plugs, wires, fuel filter, and sea-foamed the fuel tank. everything was fine for a couple days...then a p0302 code flashed but not lit solid, (i was driving a bit hard when this happened) so i cleared it and waited to see if it would happen again. it did but this time a p0300 popped, first flashing then solid. within about 10 miles of driving back home it started to run really rough. felt like it wasn't going to make it home. I changed plugs again and checked all the wires. pulled the fuel rails and cleaned the injectors( didn't have them professionally done just sprayed them down really well). cleaned maf, changed fuel pressure regulator. Im getting 50 psi of fuel pressure with the key on, 48 psi at idle and 58 psi under throttle with no load. it runs rough all across the board, idle, under throttle with no load and even worse with a load. also swapped coils, no change. bank 1 looks to be running super lean. Im at a bit of a loss. I even drained all the fuel and replaced it with fuel from a different gas station just to be safe. thanks in advance for any help/opinions
    The p430 code means catalyst system low efficiency bank 2

    The p0300 code means a engine mifire detected

    Both codes point to the cats going bad
    I have seen this happen before in a ford truck

    It kept bogging out and wanted to die under load and never wanted to idle right

    It also showed it was running lean(due to the excessive back pressure)

    The cats was replaced the problem was solved

    it went through three sets of speak plugs before it was fixed but it would throw you back in the seat afterwards

    I hate to be a bearer of bad news and this being your first thread on here but it is the truth

    Ps if it is one cat bad just replace the one but it is best to replace both as the other may fail at a later date

  7. #6
    kantgetnun is offline Cadillac Owners Member
    Automobile(s): 2003 escalade ext
    Join Date
    Sep 2013
    Age
    39
    Posts
    13
    Thread Starter

    Re: First post...and big problem...

    I had a feeling on the cats after the p0340 popped. I went ahead and ordered the manga flow direct
    Replacements. They should be here in the morning. We will see then! Hopefully no permanent damage to
    The engine was done.

  8. #7
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,871
    Quote Originally Posted by kantgetnun
    I had a feeling on the cats after the p0340 popped. I went ahead and ordered the manga flow direct Replacements. They should be here in the morning. We will see then! Hopefully no permanent damage to The engine was done.
    How long was it like this?
    If not long(eg less then a month) then i wouldn't worry
    If not sure then I would get the engine checked at a gm dealer(a good gm dealer)

  9. #8
    kantgetnun is offline Cadillac Owners Member
    Automobile(s): 2003 escalade ext
    Join Date
    Sep 2013
    Age
    39
    Posts
    13
    Thread Starter

    Re: First post...and big problem...

    it all started happening this past monday, probably 10-15 miles on it after the p0300 popped along with 20-30 minutes of running in the garage for diagnostic time.

  10. #9
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,871
    Quote Originally Posted by kantgetnun
    it all started happening this past monday, probably 10-15 miles on it after the p0300 popped along with 20-30 minutes of running in the garage for diagnostic time.
    Ok then you shouldn't have to worry about damage to the engine as long as you get the cats replaced ASAP

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting