URPA Sensor Bench Test?
Cadillac
 

Cadillac Forums | Help Us Help You | Advertise | Cadillac Parts | Cadillac News | Cadillac Classifieds / (Old System)

Cadillac Technical Archive | Cadillac Dealers | Cadillac Reviews | Cadillac Dealer Reviews | Cadillac Vendors

CadillacForums.com is the premier Cadillac Forum on the internet. Registered Users do not see the above ads.
+ Reply to Thread
Results 1 to 2 of 2
Cadillac Escalade, EXT and ESV Forum - 1999 - 2006 Discussion, URPA Sensor Bench Test? in Cadillac Escalade Forums; Hi Crew! I want to firstly say thank you to all of you for helping out with the issues that ...
  1. #1
    starnold is offline Cadillac Owners Member
    Automobile(s): 2005 Escalade Gold Edition
    Join Date
    Jan 2013
    Posts
    12

    URPA Sensor Bench Test?

    Hi Crew!
    I want to firstly say thank you to all of you for helping out with the issues that pop up on our Cadillacs!
    I recently had one sensor go bad on my 2005 Escalade and was able to diagnose which one and get a replacement on e-bay. Now I have another that has gone out! I know which one is showing as bad, but was wondering if there is a way to bench test the sensor itself? I put one of the other working sensors in place of the bad one and it also shows bad. I was also wondering about the wiring? Anyone have issues with that too?
    Thank you in advance!
    Seth

  2. Remove Advertisements
    CadillacForums.com
    Advertisements
     

  3. #2
    the cadillac man's Avatar
    the cadillac man is offline Cadillac Owners Master
    Automobile(s): 03 cadillac escalade
    Join Date
    Mar 2011
    Location
    speedwell tn,
    Posts
    7,534
    Quote Originally Posted by starnold
    Hi Crew!
    I want to firstly say thank you to all of you for helping out with the issues that pop up on our Cadillacs!
    I recently had one sensor go bad on my 2005 Escalade and was able to diagnose which one and get a replacement on e-bay. Now I have another that has gone out! I know which one is showing as bad, but was wondering if there is a way to bench test the sensor itself? I put one of the other working sensors in place of the bad one and it also shows bad. I was also wondering about the wiring? Anyone have issues with that too?
    Thank you in advance!
    Seth
    More then likely its the wiring harness not the sensor

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Bookmarks

Cadillac Posting Rules

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
Read about Lincoln | Buick | Kia Forte Forum
Need products for your Cadillac? Check out your options at the links below:

custom floor mats | Cadillac Chrome and Black Chrome Wheels | window tinting